Rock64 no audio output

speaker-test is silent.

alsamixer detects the card “rockchip,rk3328” but shows this message:
“This sound device does not have any controls.”

i’ve found people on the pine64-forum from different distros who changed their asound.conf to change ctl and pcm to 1 but it doesn’t do anything for me.

another answer is about adding a node to the device tree in ayufan’s kernel.
which doesn’t apply here since the node exists.


$ cat /proc/device-tree/analog-sound/status

is there a way to enable it?

We patch in HDMI sound card on Rock64 in our kernel, so it should be there.
But there is no Analog sound in the mainline kernel it seems.

The Roc-CC seems to have gotten an analog sound node recently, so you can try [patching that in] your kernel.

hi @Strit

thanks for your answer.

i went and had a look at the hdmi-sound node.
the node exists.

$ fdtget /boot/dtbs/rockchip/rk3328-rock64.dtb /hdmi-sound status       

i’ve tried enabling the analog-sound node:

sudo fdtput -t s /boot/dtbs/rockchip/rk3328-rock64.dtb /analog-sound status okay

but without effect :-/

it was enabled on 6. Jan in the upstream kernel along with some other changes.

If the kernel produces the sound card, and it’s listed with aplay -l, then it’s a matter of configuring it in your environment.

Maybe it needs a special asound.conf file, like the Pinebooks.

ok. i was under the impression that it wouldn’t work with status: "disabled".

with the status set to “okay” and after running speaker-test (unsuccesfully), programs like aplay -L just freeze.
before running speaker-test, aplay -L works just fine and gives:

    Analog, ff010000.i2s-rk3328-hifi ff410000.codec-0
    Default Audio Device
    Analog, ff010000.i2s-rk3328-hifi ff410000.codec-0
    Default Audio Device

with analog-sound.status set to disabled again, this is the output of aplay -L:

    rockchip,rk3328, ff000000.i2s-i2s-hifi i2s-hifi-0
    Default Audio Device
    rockchip,rk3328, ff000000.i2s-i2s-hifi i2s-hifi-0
    Default Audio Device

i had hoped to see separate analog and HDMI devices.

then i should probably stop tinkering with the device tree :smiley:

i’ll report if i find a way of getting it to work with alsa config.

in the meantime, i found this.

Yeah, it’s merged for kernel 5.12. You can test linux-rc in unstable branch, to see if it works. :stuck_out_tongue:

With linux-rc, there are these three devices:

$ aplay -L | grep "^default"

very promising!

it seems like a good direction but i don’t suppose it will save me from digging deeper into ALSA…

forgot to add: sound works - just no controls…

cvlc --play-and-exit

I’ve tried to understand how and when ALSA loads the card configuration, tried many file names, forced syntax errors, done lots of reboots…


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.