Rock pi 4B does not boot

Hi, I have a rock pi 4b that I had in the past been able to boot with an older img. Now I can’t get it to boot with the newer img’s, I’m using etcher to flash the img as I have in the past. I can flash ubuntu and Debian with no issues. is there something that Manjaro Arm has changed that effects the boot process. I have read that Rock pi4 requires 4 small partitions to boot, as I look into the manjaro iso it only has 2 partitions, while Deian has 4 small partitions. Is there something that I’m missing. any help would be grately appriciatade.

The newest images for the Rock Pi 4B is 20.10.

The ones marked rockpi4c will not work on a 4b.

1 Like

Thank you guys for your reply and I’m sorry that I did not get back to you sooner, but that said the img that is set for the Rock pi4B will not boot no matter what method I use to flash SD card or the Emmc module, again you might want to look at the amount of partitions needed for this sbc to boot. This is only specific to the rock pi4B, also if you look at the Debian img it has 4 small partitions before the 2 actual partitions. I don’t know how to change this in an arm environment I could do it with a regular pc iso but with arm I don’t know how to manipulate the iso, but I’m willing to learn because Manjaro is my main daily driver and I’m trying to make it in my SBC.

The number of partitions are only defines by the Distro. The Rock Pi 4B does not care how many partitions there are. It only cares if the boot firmware is placed where it expects it.

So to be clear, you downloaded the Manjaro-ARM-kde-plasma-20.10-rockpi4b.img.xz file. Then either extracted it and flashed it to the SD card or flashed it with Etcher. Wait until it’s done, put it into the Rock Pi 4B, connect HDMI, keyboard and power and it does nothing?
Does it show the green power LED?
Does it show anything on the screen?

If it does have green LED lighting up, but nothing on the screen, I would need UART output to be able to help anymore.

1 Like

Ye , I downloaded the latest Manjaro-Arm-xfce 20.10 for the rockpi4b.img.xz filethen i flashed it to both micro sd and the EMM module with etcher, dd, gnome disks, everyway I can flash that works on every other device numerous times my Rock pi4b is the V1.4 I have two leds one green and one blue when everything is hooked up I turn it on and the green light comes on like all other os’s then about 5 seconds later the blue light comes on just like the other os’s at this point the blue light should start blinking about 5 more seconds after it comes on, but this is where it just does not do anything. I have waited as much as 1/2 hour and nothing, my screen times out after that. Debian and ubuntu does not do this. should I try the kde iso?
I’m downloading the kde and try that to see if it’s any different and will update this post.

So as a follow up, I have downloaded the kde iso with the same result, I can’t believe that there are not other people with this problem specially since I can boot fine with other distros except Armbian.
At the same time I found this article, Rockpi4/dev/spi-install - Radxa Wiki that might do the trick but, I don’t think i have the skill to do it, so for now I will check back on later releases to see if this boot issue could get fixed, and I will continue with Debian for now.
Thank you for the help.

Yeah, it’s a weird issue for sure.

Also, make sure the “OTG” switch is not turned on.
It’s a little switch next to the power plug input. Try putting it to the other side.


I just wanted to give an update, on the boot issue. Reading through a bunch of posts I have found that if you short out pin #23 with 25 before turning the computer on it will totally boot. I also know that there is a code to by pass that, but for now I have a bridge between the two pins and it works fine. So for those that would be looking at this post and are having boot issue with the Rock pi4B, just short out the #23 with 25 pin and you are good to go.

PIN 23 is for SPI flash and PIN 25 is GROUND.

Did you mess with SPI flash at all on the board, when you booted either Debian or Ubuntu?

1 Like

For Debian and Ubuntu, no it just booted with out any mod.

I have Manjaro booted right now and I’m trying to update, but it’s just get stuck in synchronizing package databases, so I’ll have to figure that
I know that you are not working of the older kernels like 4.4xx, but someone on nother forum told me that the Rockpi 4B works better with the older kernel, Don’t know, but that said I have now tried Armbian and Twister and Manjaro and they all have to se the short pin mod.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.