Rk3588 issue with BTRFS


I installed the new image for Orange Pi 5 Plus.
I have a problem mounting BTRFS partition. I tried to find the cause for this and it seems like there is no kernel module for BTRFS. I looked in the code, config · andy · manjaro-arm / packages / core / linux-rk3588 · GitLab hopefully this is the appropriate one, and it looks like the config does not include support for this file system. It has the line:

CONFIG_BTRFS_FS is not set.

Is there a problem with this support at this time? Maybe something planned for the future?

Thank you,

1 Like

Try installing btrfs-progs if it’s not.

I tried installing it but it said that btrfs-progs was already installed. Must have already come included on the Gnome image I was using.

Make sure the module is added in /etc/mkinitcpio.conf


MODULES=(vc4 btrfs)

Then run sudo mkinitcpio -P and reboot.

You can confirm if the module is loaded with dmesg | grep -i btrfs

The kernel is not compiled with btrfs support. I has to be re-compiled with it enabled. @spikerguy

1 Like


Pushed to gitlab

Will push it to unstable once built.

1 Like

Thank you, will test it once it is out.