Rickrack, require openssl-1.0 as depedency

Hello, I was trying to install rickrack-bin. But it failed because openssl-1.0 failed to compile. One post says it’s outdated but I’m still not sure how to proceed.

I tried to edit pkgbuild and removing openssl-1.0 from rickrack but it still says, ==> Missing dependencies: -> openssl-1.0.

What else can I try?

note, for some reason, after I removed openssl-1.0 from rickrack pkgbuild, then I tried to reset the pkgbuild. Pamac doesn’t try to compile openssl-1.0 anymore. And if I tried to manually compile it, with pamac, it will just says, “target not found: openssl-1.0”


Install openssl-1.1 package from official repository, then build the package from AUR that requires > openssl-1
If that doesn’t work, you can build/install AUR (en) - openssl-1.0-hardened

1 Like

Hmm, this was already installed when it didn’t work.

Yes yes!! this works, thank you for your assistance.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.