RGB Keyboard Lighting Unable to Change with Alienware Laptop

Hello everyone, I am new to Linux. I have Manjaro KDE Plasma on an Alienware m15 r4 laptop. I have two things left with my setup: 1) change the RGB keyboard lighting, and 2) set the fan speed control.

For the keyboard lighting, I have tried AlienFX, OpenRGB, and AKBL. AlienFX seems to install, but when opening the app it says “No supported Alien FX controllers found”, and I am unable to use it.

When I run OpenRGB, a window pops up and says “One or more I2C/SMBus interfaces failed to initialize. RGB DRAM modules and some motherboards’ onboard RGB lighting will not be available without I2C/SMBus. On Linux, this is usually because the i2c-dev module is not loaded. You must load the i2c-dev module along with the correct i2c driver for your motherboard. This is usually i2c-piix4 for AMD systems and i2c-i801 for Intel systems." Unfortunately, I don’t understand what this means or how to obtain and load this module, and their troubleshooting page says they can’t help with Linux. And upon closing this initial window, OpenRGB has no devices listed. If I choose Rescan Devices, the initial “One or more I2C/SMBus interfaces failed…” window pops up again, so I am unable to use this app.

And for AKBL, I followed their installation steps:

  1. Download the stable branch.
  2. Install the dependencies:
    ArchLinux: pacman -Suy systemd gtk3 python python-gobject python-cairo python-pyusb python-serpent python-pyro also gir1.2-ayatanaappindicator3-0.1 is necessary for the app indicator, such dependency seems to be in the AUR.
  3. Execute the setup file.

Everything downloaded except for the “gir1.2-ayatanaappindicator3-0.1” dependency. I don’t know what to type ahead of this particular command to install it with the terminal. I type “sudo pacman -Suy gir1.2-ayatanaappindicator3-0.1” and input my password, but it says “error: target not found: gir1.2-ayatanaappindicator3-0.1” But regardless of this indicator dependency, when I click on the setup file, it opens a window called “akbl-stable/setup–Ark” where there are 150 lines of computer language which is mostly foreign to me. I don’t know how to use this, or what it is that I’m missing here, or if this app is even a viable option. So, I’m stuck here as well.

I have been troubleshooting this for days just looking to change the keyboard lighting. If all else fails, can I download the Alienware Command Center app and use it with WINE? I’d also prefer not to reinstall a partition of windows just to make the lighting and fan changes if it’s possible (I haven’t even addressed the fans yet because I have been preoccupied with changing the lights).

Thank you very much in advance for your time and any help or guidance you can provide. Cheers.

System Details:
Operating System: Manjaro Linux
KDE Plasma Version: 5.24.6
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.15.55-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8750H CPU @ 2.20GHz
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1060/PCIe/SSE2

pacman does not handle the AUR in Manjaro. For that you need pamac. :arrow_down:

pamac build libayatana-appindicator

Not normally. wine does not have access to the raw hardware.

Sorry, I cannot help you with the rest of your problem, though.


Oh, goodness. I’ve seen pamac written before and thought it was a typo for pacman. Maybe my vision was hindered by the brightness of my keyboard :wink: I just searched for pamac in my application menu and it shows the ‘add or remove’ application, which I have been using (I guess I just didn’t know it was called pamac). So, the first two apps I mentioned (AlienFX and OpenRGB) are from AUR using pamac, but the AKBL app was what I copied and pasted into the terminal from a GitHub page (GitHub is still a bit of a mystery for me at the moment). Thank you very much for your help letting me know this.

And no worries. I’ve only had Linux for a week, so I have much to learn about both Linux and computers in general. It’s worth it though, I think this operating system is wonderful, and if the keyboard lights can’t be changed because of my laptop, then so be it. At least it’s not an ugly color :wink:

See the instructions here:

libayatana-appindicator used to be in the AUR, but it was imported to the Arch community repo a few months ago.

1 Like

Thank you very much for your help. I opened OpenRGB before clicking on your link and it was working somehow. After the window telling me I need those modules pops up, “Dell G Series LED Controller” was listed under devices. And it operates somewhat wonky. The brightness doesn’t always stay, and the Alienware-head power button keeps flashing even though the static option is selected. It also doesn’t show a keyboard layout when I toggle the LED view, nor does it have anything for my macro keys. I started following your linked steps in hopes it will run correctly, but I am stuck.

Within SMBus Access, under the 4th bullet-point “Allowing access to SMBus” I click on Intel. It reads in part:
sudo modprobe i2c-nct6775 - Secondary controller for motherboard LEDs (requires kernel patch)

I type:
sudo modprobe i2c-nct6775
I get back:
modprobe: FATAL: Module i2c-nct6775 not found in directory /lib/modules/5.15.55-1-MANJARO

I click on “kernel patch” in the parentheses of that step and it opens a link to a secondary set of steps for that patch.

The 3rd step of the kernel patch link says:
Checkout a version that will work with your system (5.1 is the latest I got to work with nVidia drivers in Debian stable, but the newer drivers in testing work up to 5.4)
git checkout master

When I type: git checkout master
It says: Already on ‘master’
Your branch is up to date with ‘origin/master’.

On step 4, I go to apply the patch:
_patch -p1 < /home/user/OpenRGB/OpenRGB.patch
zsh: no such file or directory: /home/user/OpenRGB/OpenRGB.patch

This is where I’m stuck. Would you be kind enough to let me know what I’m doing wrong here? And thank you again for your time any help you can provide.

i2c-dev and i2c-piix4 / i2c-i801 should already be loaded by default. What’s the output of:

lsmod | grep i2c


sudo i2cdetect -l

Hello, thank you for replying again.

Here is what I got:

lsmod | grep i2c
i2c_dev 24576 0
i2c_hid_acpi 16384 0
i2c_hid 40960 1 i2c_hid_acpi
i2c_i801 45056 0
i2c_smbus 20480 1 i2c_i801

sudo i2cdetect -l
sudo: i2cdetect: command not found

You’ll need to install i2c-tools for that command.

Hello. I installed the i2c tools from pamac.

sudo i2cdetect -l
i2c-0 smbus SMBus I801 adapter at efa0 SMBus adapter
i2c-1 i2c Synopsys DesignWare I2C adapter I2C adapter
i2c-2 i2c i915 gmbus dpb I2C adapter
i2c-3 i2c i915 gmbus dpc I2C adapter
i2c-4 i2c i915 gmbus misc I2C adapter
i2c-5 i2c i915 gmbus dpd I2C adapter
i2c-6 i2c AUX B/DDI B/PHY B I2C adapter
i2c-7 i2c AUX D/DDI D/PHY D I2C adapter
i2c-8 i2c NVIDIA i2c adapter 1 at 1:00.0 I2C adapter
i2c-9 i2c NVIDIA i2c adapter 2 at 1:00.0 I2C adapter
i2c-10 i2c NVIDIA i2c adapter 6 at 1:00.0 I2C adapter
i2c-11 i2c NVIDIA i2c adapter 7 at 1:00.0 I2C adapter
i2c-12 i2c NVIDIA i2c adapter 8 at 1:00.0 I2C adapter

Notice The OpenRGB SMBus Access section states:

SMBus access is necessary for controlling RGB RAM and certain motherboard on-board LEDs.

However, you said you want to control the keyboard lighting and you do not have the i2c-nct6775 controller, anyway.

It does not appear OpenRGB supports Alienware laptop keyboards. See the Supported Devices and Alienware AlienFX wiki entries.

Did you try AlienFX or AlienFX Lite? They’re both available in the AUR.

Sincerest apologies for the brief hiatus. I did try AlienFX and AlienFX Lite, but they did not work. It says "No supported Alien FX controllers found” It’s all good, though. Thank you so much for all your help with this.

I can get OpenRGB to somewhat work in applying different colors and saving the theme (it’s utilizing the Dell G Series LED Controller device), but the brightness setting doesn’t save correctly within the theme, I can’t change the macro keys, and the alien head power button doesn’t stop flashing. Seeing as it seems unsupported, it’s no biggie. I’ll just keep my keyboard set to its current Manjaro green color, fix the flashing power button with my special Alienware repair kit (some electrical tape), and call it day.

Cheers :slight_smile: