Reverting from Nvidia drivers to open source (SOLVED)

Hi there

I have what i hope is a quick and easy question.

I’m returning to Linux after a few years of not using it.

After a clean install, when i install the Nvidia drivers following the Wiki

sudo mhwd -a pci nonfree 0300

a reboot gets me a black screen.

I’m not worried about using the Nvidia drivers (though happy if I can get them to work) so could someone let me have the chmod commands I can use from my USB stick to revert back to the open source drivers?

Any help much appreciated,

TIA

It’s in the wiki: Configure Graphics Cards - Manjaro

Thanks but I need to access the installation from my Live USB, as my install is unavailable and it was how i go about accessing the installation that i was looking for.

It might be easier just to reinstall.

It’s the same. You just need to chroot into your installation first with manjaro-chroot -a

Hi @Azazello, and welcome!

You’ll need to enter a chroot environment, and reinstall/revert the drivers from there:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with an LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment oon your computer, so any changes you make will persist after a restart.


From there, you’ll need to remove the current, proprietary driver:

Run:

mhwd

To find the name of the current driver in use. Then uninstall the driver:

mhwd --remove <driverName>

Where <driverName> is the name of the driver noted in the previous step.

  1. To install the open-source one:
mhwd --install pci video-linux

Hold your thumb and reboot.

Hope this helps!

All worked well thanks, just needed the chmod command!

Thanks both of you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.