Restrict the mouse cursor to stay on primary screen - how?

How can I restrict the mouse cursor to stay on the primary screen? I run KDE on Wayland.

In my setup I use a TV as screen, and I also connect my AVR directly from the PC because the TV and the AVR refuse to cooperate. The AVR tells the PC that it is a screen, and therefore the PC sees two screens and fuse them to one display. When I happen to push the mouse cursor to the AVR part of the display, the AVR “screen” becomes the active one, and Krunner and programs open there, invisible to me. That causes confusion, confusion leads to suffering, and suffering leads to the dark side …

I cannot disable the AVR “screen” in the system settings, because then the PC will not send the sound signal to the AVR.

I would like to restrict the mouse cursor to stay on the primary screen. What should I do to make that happen?

You can mirror the screen rather than having two separate screens and use workspaces instead. Not sure if this is what you want or if the resolution would look good on a TV screen, but this is my setup with an external monitor.

wow, i don’t think that it’s possible but i’m sure you should ask this specific question in the kde/plasma forum.

https://discuss.kde.org/

Thank you Olli, guss77 at discuss.kde.org gave me the solution.

I ran kscreen-doctor output.1.position.2000,300 in Konsole to create a gap between the screens, and it keeps my mouse cursor on the primary screen, just like I wished :grinning:

The Plasma System Settings Display Configuration complains “Gaps between displays are not supported. Make sure all displays are touching.” , but it does not reset the position to enforce it, and the setting keeps working after a reboot.

@yoel: my TV is 4k and the AVR “screen” only goes to 1080p, so I did not try mirroring.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.