Restore the /boot partition

So a long time ago when I first installed Manjaro I assigned 200mb to the /boot partition and another 200 to the /boot/efi. Now as I am trying to upgrade my kernel to 5.17 I get the error that the disk is full. I boot onto live medium and resize the boot partition to 500mb along with the /boot/efi. Reboot into my main system the disk is still full.

Some online research later, I used the df command and the fdisk command to see what is wrong. Fdisk does say the partition is 500mb but df says that the filesystem is still 200mb.

Is there any way to fix this while leaving my / partition intact?

Quick notice, I tried the resize file system command, but I got an error saying “Bad magic number”. I also tried restoring the superblock from a backup but all of them were corrupted.

post formated output from:
inxi -Fazy
sudo parted -l && lsblk
sudo efibootmgr -v

Keep in mind I am dual booting with windows on another drive

inxi -Fazy:

  Kernel: 5.17.1-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/vmlinuz-5.17-x86_64
    root=UUID=d0eba16b-b8cc-4619-a9a0-360935bbb64e rw quiet
    resume=UUID=06e94534-c419-4d85-9a99-68e78006d5ae udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: HP product: OMEN by HP Desktop PC 880-p1xx v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: HP model: 8437 v: 1.3 serial: <superuser required> UEFI: AMI v: F.51
    date: 12/10/2019
  Info: model: Intel Core i5-8400 bits: 64 type: MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
    desc: 1x9 MiB
  Speed (MHz): avg: 2730 high: 3899 min/max: 800/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 939 2: 2332 3: 3441
    4: 3899 5: 3450 6: 2322 bogomips: 33613
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Hewlett-Packard
    driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1c02 class-ID: 0300
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
    s-diag: 692mm (27.26")
  Monitor-1: HDMI-0 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.23")
    diag: 685mm (26.97") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
  Device-3: Generalplus USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:2 chip-ID: 1b3f:2008
    class-ID: 0300
  Sound Server-1: ALSA v: k5.17.1-3-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 04:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-13:7 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 1.94 TiB used: 784.33 GiB (39.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLW128HEGR-000H1 size: 119.24 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: CXB73H1Q temp: 32.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1SB102
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: HPH4 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LX015-1U7172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: SDM1 scheme: GPT
  ID-1: / raw-size: 100.26 GiB size: 98.12 GiB (97.87%)
    used: 68.81 GiB (70.1%) fs: ext4 dev: /dev/sda6 maj-min: 8:6
  ID-2: /boot raw-size: 500 MiB size: 196.9 MiB (39.38%)
    used: 196.9 MiB (100.0%) fs: vfat dev: /dev/sda4 maj-min: 8:4
  ID-3: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda7 maj-min: 8:7
  System Temperatures: cpu: 30.0 C mobo: 27.8 C gpu: nvidia temp: 45 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 35%

sudo parted -l && lsblk

Model: ATA ST1000DM003-1SB1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      17.4kB  16.8MB  16.8MB                  Microsoft Reserved partition  msftres
 2      16.8MB  796GB   796GB   ntfs            Basic data partition          msftdata
 7      796GB   804GB   8590MB  linux-swap(v1)                                swap
 4      804GB   805GB   524MB   fat32
 5      805GB   805GB   524MB   fat32                                         boot, esp
 6      893GB   1000GB  108GB   ext4

Model: ATA ST1000LX015-1U71 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      17.4kB  16.8MB  16.8MB               Microsoft reserved partition  msftres
 2      16.8MB  1000GB  1000GB  ntfs         Basic data partition          msftdata

Model: SAMSUNG MZVLW128HEGR-000H1 (nvme)
Disk /dev/nvme0n1: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  274MB  273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB  16.8MB               Microsoft reserved partition  msftres
 3      290MB   127GB  127GB   ntfs         Basic data partition          msftdata
 4      127GB   128GB  1028MB  ntfs         Basic data partition          hidden, diag

loop0         7:0    0     4K  1 loop /var/lib/snapd/snap/bare/5
loop1         7:1    0 219.4M  1 loop /var/lib/snapd/snap/code-insiders/1001
loop2         7:2    0 219.4M  1 loop /var/lib/snapd/snap/code-insiders/1002
loop3         7:3    0 110.6M  1 loop /var/lib/snapd/snap/core/12834
loop4         7:4    0 111.6M  1 loop /var/lib/snapd/snap/core/12941
loop5         7:5    0  61.9M  1 loop /var/lib/snapd/snap/core20/1405
loop6         7:6    0  61.9M  1 loop /var/lib/snapd/snap/core20/1434
loop7         7:7    0  70.9M  1 loop /var/lib/snapd/snap/flameshot/x1
loop8         7:8    0  65.2M  1 loop /var/lib/snapd/snap/gtk-common-themes/1519
loop9         7:9    0 424.2M  1 loop /var/lib/snapd/snap/kde-frameworks-5-qt-5-15-3-core20/8
loop10        7:10   0  43.6M  1 loop /var/lib/snapd/snap/snapd/15177
loop11        7:11   0  44.7M  1 loop /var/lib/snapd/snap/snapd/15534
sda           8:0    0 931.5G  0 disk 
├─sda1        8:1    0    16M  0 part 
├─sda2        8:2    0 740.9G  0 part /mnt/DATA
├─sda4        8:4    0   500M  0 part /boot
├─sda5        8:5    0   500M  0 part /boot/efi
├─sda6        8:6    0 100.3G  0 part /
└─sda7        8:7    0     8G  0 part [SWAP]
sdb           8:16   0 931.5G  0 disk 
├─sdb1        8:17   0    16M  0 part 
└─sdb2        8:18   0 931.5G  0 part /mnt/FAST DATA
sdc           8:32   1     0B  0 disk 
sr0          11:0    1  1024M  0 rom  
nvme0n1     259:0    0 119.2G  0 disk 
├─nvme0n1p1 259:5    0   260M  0 part 
├─nvme0n1p2 259:6    0    16M  0 part 
├─nvme0n1p3 259:7    0   118G  0 part 
└─nvme0n1p4 259:8    0   980M  0 part 

sudo efibootmgr -v

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0009,0000,0005,0012,000A,000B,0008,000C,000D,000E
Boot0000* Manjaro       HD(5,GPT,8679c24f-df6c-214e-9c80-40cd84e51bd7,0x67dee000,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0005* Windows Boot Manager  HD(1,GPT,51f21006-16fd-43b3-870f-789bd7931651,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...&................
Boot0008* ATAPI CD-ROM Drive    VenMedia(b6fef66f-1495-4584-a836-3492d1984a8d,0300000001)..BO
Boot0009* OS Boot Manager       VenMedia(b6fef66f-1495-4584-a836-3492d1984a8d,0400000001)..BO
Boot000A* USB Floppy/CD VenMedia(b6fef66f-1495-4584-a836-3492d1984a8d,0500000001)..BO
Boot000B* USB Hard Drive        VenMedia(b6fef66f-1495-4584-a836-3492d1984a8d,0200000001)..BO
Boot000C* USB Floppy/CD VenMedia(b6fef66f-1495-4584-a836-3492d1984a8d,0500000000)..BO
Boot000D* Hard Drive    BBS(HD,,0x0)..GO..NO........o.S.A.M.S.U.N.G. .M.Z.V.L.W.1.2.8.H.E.G.R.-.0.0.0.H.1....................A...........................%8..........2..Gd-.;.A..MQ..L.S.3.3.Z.N.X.0.K.>..Gd-.;.A..MQ..L.9.Z.W.A.T.1.7.T. . . . . . . . . . . . ........BO..NO........o.S.T.>..Gd-.;.A..MQ..L. . . . . . . . . . . . .Q.W.6.9.J.5.E.7........BO
Boot000E* CD/DVD Drive  BBS(CDROM,,0x0)..GO..NO........o.h.p. .H.L.D.S. . .D.V.D.R.W. . .G.U.D.1.N....................A...........................>..Gd-.;.A..MQ..L.3.8.C. .1. . . . . . . . ........BO
Boot0012* UEFI: ST1000DM003-1SB102      PciRoot(0x0)/Pci(0x17,0x0)/Sata(0,65535,0)/HD(5,GPT,8679c24f-df6c-214e-9c80-40cd84e51bd7,0x5dae6000,0xfa000)..BO

I know it looks like I successfully upgraded it but now pacman refuses to update packages.

what do you mean pacman refuses to update packages? whats the error?

Not enough disk space.

so whats the output from:
journalctl --disk-usage
try clean pacman cache:
sudo pacman -Scc

Archived and active journals take up 4.0G in the file system.

And the exact error pacman was returning is

error: Partition /boot too full: 20162 blocks needed, 0 blocks free
error: not enough free disk space
error: failed to commit transaction (not enough free disk space)
Errors occurred, no packages were upgraded.

your disk is completely full …
clear your journal:
sudo journalctl --rotate
sudo journalctl -m --vacuum-time=1s
clear pacmans cache:
sudo pacman -Scc

The issue here is not pacman is that my boot file system size is incredibly incorrect and the superblock is corrupted with no working backups. The system boots, the superblock just has “bad magic number”.

so try running repair from live usb… in live usb install gnome disk and select repair filesystem

You may have too many kernels installed.
Possibly old ones that you do not use but which take up the space in the /boot partition.
Check that.

You can have more than one - but more than 3 is probably a bit over the top.

when you resize a partition
you need to also resize the filesystem
to fit the new partition size.

I also made sure to remove the old kernel
At least that’s what the manjaro settings manager said.

you have damaged your partition: bad magic number, you need to try to repair it

And is that possible without a single working backup of the superblock for the file system?

i really have no idea, youll have to try it, nothing to lose:
so try running repair from live usb… in live usb install gnome disk and select repair filesystem

One booting into ubuntu because the disk utility refuses to work on my manjaro iso for some reason it did nothing df still shows 200mb

did you tried to repair it? … and try running smart status on your disk

I did press repair and said repaired successfully and in reality it did nothing.

i dont know what to do, except to clear pamacs cache to make some space and maybe reinstall completely the bootloader from live usb