Restart instead shutdown dual boot

thank you but its not the problem the problem is when i work with laptop or opning files or graphical things laptop going to suspend while im working and also when i click on power off its going to restart

Ok @darky2000 it sounds unbelievable to me, but I try to believe you.

Step by step now. About the shutdown/restart problem:
Can you open a terminal and type poweroff into it? Run it by pressing ENTER. Does it restart your laptop?

why should i lie but when i enter the command and press enter its going to shut down and after 2 sec turning on again and showing grub like before

Did you try as @megavolt suggested? Defending your integrity will not fix the issue… :upside_down_face:

Hardware issue? Heat related after running for some time?

how can know if the problem is from hardware or software
*and also i have windows and manjaro on one drive and i dual booted them and i dont have this problem in windows

You should always state in any support posts that you are dual booting windows. It would be a good idea to read the tutorials/wiki regarding dual booting. As always when dual booting Windows, make sure that Windows is always completely shutdown and that fastboot, hibernation, hybrid boot are disabled in Windows.

If you have a hardware problem related to temperature and the computer shuts down because of it, you need to monitor temperature. I am not sure if inxi is accurate but inxi -s will show temperature(s). Check to see if vents are dust clogged, if fans are freely moving and that memory is properly inserted.

Did you look in UEFI/BIOS? Is there a BIOS update for your laptop?
swapfile or swap partition would be a good idea as well.

i think you skipped the part where you need to check BIOS for Wake-on-X and disable if enabled. please read the entire post, you cannot expect people to keep on reminding you to do stuff when you just do the first thing asked skip everything else.

if you are dual booting, make sure that “fast-boot” in windows is disabled, and never ever restart windows and boot into linux, manjaro or otherwise, always shutdown windows and then switch on to boot into linux (as trivial as it sounds it is a fact)

if you do all this and it is still an issue, then open file /etc/default/grub

$ sudo nano /etc/default/grub

find line reading GRUB_CMDLINE_LINUX_DEFAULT=........, at the end of line append this;


CTRL + S to save and CTRL + X to exit

then run;

$ sudo update-grub

and reboot. and see whether the same behavior persists.

@megavolt @jrichard326 from limited searching i’ve done, this is NOT as remotely possible in the wild. apparently happen with certain hardware combos.

“quirks” indeed!!!

1 Like

I am horrified. :scream: Such things are real? Never had a point of contact with such misconduct. Sorry @darky2000 for disbelieving you.But hey, I’ve learned something: Even with such basic functions, the manufacturers’ developers make mistakes. Seems like a Windows driver or an exception for Windows in the UEFI irons out this misbehavior.

Just for the record:

    xhci-hcd.quirks         [USB,KNL]
                   A hex value specifying bitmask with supplemental xhci
                   host controller quirks. Meaning of each bit can be
                   consulted in header drivers/usb/host/xhci.h.

The kernel’s command-line parameters — The Linux Kernel documentation

1 Like

thx be hones im a new user
but about hardware problem idk if i have but i dont have problem in windows but about fast boot i think last time i cheked out in bios it was enable
dose disabling them fix my problem or i must reinstall everything again :face_with_spiral_eyes:

i followed ur solution and still when i poweroff its going to shutdown and after 3 sec turning on again
and disabeld fastboot
and also in bios there is an option like
idk what is that but maybe help

hello thx but how i can fix it can u explain more ?

this is somewhat similar, solution was to install, laptop-mode-tools

i think i should deal with this problem

i think you should first undo this

and then install yay

then install laptop-mode-tools using command;

$ yay -S laptop-mode-tools

agree to all required dependency installations if any and then reboot and see if it solves the reboot issue. if it does and you see the boot process taking significantly longer to boot, then;

open file /etc/default/grub

$ sudo nano /etc/default/grub

find line reading GRUB_CMDLINE_LINUX_DEFAULT=…, at the end of line append this;


CTRL + S to save and CTRL + X to exit

then run;

$ sudo update-grub

and reboot.

why i cant install laptop toold

Because you will seldom get answer, if you keep posting pictures instead of text :wink:

Because you did not follow the instructions that were given, maybe. Do not run makepkg as root. I don’t see why you need yay, anyway. Your choice, I guess. The command as posted above is:

$ yay -S laptop-mode-tools


 pamac build laptop-mode-tools

Why not explain it clearer, he is clearly not that used to terminal use or linux!

@darky2000 you miss-typed the fist attempt to install, you missed the “s” and then ran the same command but adding sudo, but in that command you included the trailing s.

pamac build laptop-mode-tools
instead, it is the built in package handler for manjaro.

If people are asking for logs, copy the text from your terminal by marking it with your mouse and then right clicking and choose copy.
Then click the “preformated text” (</>) here at the top of the window you are typing your response and paste the text in between.

If you have further questions, please ask!
If you feel you have found your sollution here in the thread, it is always nice for the forum if you mark the post you found as “sollution”. That way it will be included in your original post so other users who have a similar problem as you will find the correct post containing the solution immediately. :slight_smile:


To install laptop-mode-tools from the AUR, you should first install the base-devel package (“basic tools to build Manjaro Linux packages”).

pamac install base-devel
1 Like

:blue_heart: thanks :)