Resolved - Trying to switch to new kernel, but grub doesn't show in startup

I’ve been trying to upgrade to kernel 5.15. But GRUB won’t appear on start-up. Now what?


1 Like

press shift when its booting

1 Like

Well, I wasn’t expecting such a quick response. Thank you.

How ever. I have tried holding down the shift key. But it hasn’t shown up.

System will boot on 5.15 if you installed it.

It’s still on 5.14, even though 5.15 is in there.

How did you install the kernel?

Do not hold, ~tap~

1 Like

If you want the GRUB menu visible at every boot, edit /etc/default/grub and look for the line that reads… :arrow_down:


Change that into… :arrow_down:


Save the file and then run… :arrow_down:

sudo update-grub
1 Like

I tapped. Unfortunately, no change.

These were already set.

I"m looking into other ways to update grub. I will come back to this.

I think you are referring to

sudo update-grub

Check if GRUB_TIMEOUT=0.0
if yours look like that then change it to

and then execute

sudo update-grub

The line above tells the changes you made to grub.It doesnt update the grub like pamac does.

Yes, I was butterfingering ─ too much going on in my mind at the time I wrote this ─ sorry.

I have corrected it in my post higher up. Thank you for pointing out that blunder. :blush:

Then the only other explanation I can come up with is that you have more than one GNU/Linux system installed on that computer, and that the GRUB belonging to one of the other distros is in control.

Remember that in a UEFI setup, only the first stage of GRUB is installed in /boot/efi as a UEFI executable, and that the rest of GRUB ─ including the menu and the timer ─ is then installed in /boot proper. So there are always two distinct filesystems involved, i.e. the EFI system partition and whatever partition holds the content of the distribution’s /boot directory.

Anyway to me all this is not going forward, this is circling, avoiding the real question and issue.

If you properly installed kernel 5.15 when previously using 5.14, you SHOULD have been on kernel 5.15 on next boot. If you are not on 5.15 this shows that either you have modified your /etc/default/grub file to change the default behavior, or you broke this config file (or another config file for grub generation is broken). Please answer the questions.

How did you install the kernel?
What is content of /etc/default/grub?
What is the content of /boot/grub/grub.cfg?
What is the output of ls -al /boot
What is the output of ls -al /boot/grub

To me this is a proper starting point to start seeing through this.

1 Like

It turns out that you were on the right track, but Shift is out dated. Some where the standard has changed to Esc

1 Like

I only have Manjaro. Was able to get GRUB, so on that I think I have it resolved.

As for the kernal, there is on new problem.

This is what shows in System settings:

And this is what shows in Grub

So there is 5.15, but it isn’t appearing in GRUB.

EDIT: 5.15 came with the latest update of Manjaro.

1 Like

Grub timeout was 7. I entered that when I was first noticing the problem. I also have updated grub with the command you provided.

OK I will let others handle your issues, twice you ignore what I write and answer random things. I’m done.

1 Like