Resolution is automatically lowered a few seconds after I log in


I was playing a wine game that crashed. After that my screen resolution was lowered. I went to KDE settings and it says that my resolution is still 1920x1080.

I tried rebooting and after I boot my resolution is 1920x1080 for a few seconds and than it is lowered.

Edit: “this isn’t true I made a mistake (I noticed that compositing isn’t working either.)”

I ran xrandr and inxi -GSaz commands and it says that I have 1920x1080 resolution and that I am using nvidia drivers.

$ xrandr
Screen 0: minimum 8 x 8, current 1600 x 900, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 520mm x 290mm
   1920x1080     60.00 +  59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00* 
   1440x900      59.89  
   1280x1024     60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      70.07    60.00  
   800x600       72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       72.81    59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
$ inxi -GSaz
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_MONETARY = "sl_SI.UTF-8",
        LC_MEASUREMENT = "sl_SI.UTF-8",
        LC_TIME = "sl_SI.UTF-8",
        LC_ADDRESS = "sl_SI.UTF-8",
        LC_TELEPHONE = "sl_SI.UTF-8",
        LC_IDENTIFICATION = "sl_SI.UTF-8",
        LC_NUMERIC = "sl_SI.UTF-8",
        LC_NAME = "sl_SI.UTF-8",
        LC_PAPER = "sl_SI.UTF-8",
        LANG = "en_SI.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
  Kernel: 6.1.29-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=61f6613f-cf36-4f91-bbe6-ea9f368721af rw quiet
    resume=UUID=ce62320f-2e92-4e85-b9ee-bffa47381216 sysrq_always_enabled=1
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Device-1: NVIDIA TU106 [GeForce GTX 1650] vendor: ASUSTeK driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-05) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1f0a class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 94 s-size: 432x243mm (17.01x9.57")
    s-diag: 496mm (19.51")
  Monitor-1: HDMI-0 res: 1600x900 hz: 60 dpi: 78
    size: 520x290mm (20.47x11.42") diag: 595mm (23.44") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX
    1650/PCIe/SSE2 direct-render: Yes

I updated my system which also updated my graphics drivers but the problem persists.

I tried searching online for similar cases but couldn’t find any.
Thank you for your help in advance.

Hello @Buda :wink:

xrandr says you use:

Note the asterisk *.

Also here:

Yes i know xrandr says that my resolution is 1920x1080 however the actual resolution is lower. I tried taking a screenshot to show how my screen actually looks but the captured image is in 1920x1080 resolution (when I am looking at the screen it actually isn’t). I have no idea what is going on.

No, read again. It actually says that it is 1600x900.

1 Like

OH! :open_mouth: I can’t believe I misread that every time. Thank you for spotting that. Now I am embarrassed. :sweat_smile:

Should I delete this thread since it is totally pointless?

1 Like

What does this mean in this context?

I managed to misread 1600x900 as 1920x1080 every time including the images resolution. :roll_eyes:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.