Repeted "Enter" key pressed automatically under Gnome Wayland

Hey team,

I see a keyboard input problem on Manjaro update since Oct 22 update on my DELL Vostro 13 5310 laptop. When I try to open a text file with Gvim or VSCode, the cursor in editor window keeps inputting “enter” key, which causes scrolling down of edit window in GVim, or a lot of new lines entering in VSCode. It stops only when any key (ESC, enter, space, shift, whatever) is pressed.

The issue is so annoying to a programmer, that I can’t do my coding works anymore. :frowning:

At first I was thinking it a hardware problem (key stuck maybe) until I noticed not all apps had this problem. I see Gvim and VSCode were heavily affected. Meanwhile, XEdit, Firefox (I have some web editors opened), Alacritty and gnome-terminal worked fine.

Thus I started thinking it might be software related. So, I tried to use Gnome on Xorg, and the problem was gone at all. Gvim and VSCode were back like my old friend. When I went back to Gnome Wayland, the same problem appeared again.

Is there any report on this issue? Or any guideline or suggestion to help debugging more?

Machine info =>

  1. Model: DELL Vostro 13 5310
  2. Desktop environment: Gnome 42.4
  3. Manjaro branch: testing

I’m seeing similar behavior on plain Arch. Can you try downgrading xorg-xwayland and see if the problem vanishes?

pacman -U /var/cache/pacman/pkg/xorg-xwayland-22.1.3-1-x86_64.pkg.tar.zst

Thank you @yookyookwanda ! Unfrotunately I cleared my local cache last week. :frowning: Is there any other approaches to allow me downgrade and verify?

Maybe this is far fetched - but it do sound like a common configuration file containing a newline in the wrong location. The why and where I have no clue.

You could switch to unstable - and run a full system sync.

The following is creating a partially sync system - but could provide a temporary solution.

As you are on testing branch - one option to downgrade is to switch branch to stable - then reinstall the package and switch back to testing.

sudo pacman-mirrors -aSstable
sudo pacman -Syy
sudo pacman -S xorg-xwayland
sudo pacman-mirrors -aStesting

Thank you @linux-aarhus ! I managed to get a Internete connection and upgrade system today (2022-10-29). The entering issue is gone. Maybe it’s identified and fixed. Let’s keep an eye on it and see any changes further. Thanks anyway for all the suggestions!