Removed kernel now boots to a black screen that shows my hard drives

I removed the kernel I was using which was unsupported then I installed kernel 5.10. After rebooting it goes to a black screen that just has the text that shows the hard drives, what should I do to fix this?

does that mean, that you are able to boot into the konsole (terminal)?
Maybe your VGA drivers are not loading correctly, after you did a kernel-switch (install)

I am very new to Manjaro, only know this from Debian (which I know far better than Manjaro).

PS: Switched to Manjaro about a month ago.

i am able to do ctrl+alt+f2 and then get into TTY.

which VGA card do you use?

nvidia gtx 960

just a try in the konsole (tty)

sudo mhwd -a pci nonfree 0300

then reboot.

it says

>Skipping already installed config 'video-nvidia' for device 0000:01:0.0 (03000:10de:1401) Display controller nVidia Corporation GM206 [GeForce GTX 960]

What is the output of inxi -G ?
What is the output of inxi -S ?

1 Like

What’s the output of

mhwd-kernel -li

inxi -G:

 Device-1: NVIDIA GM206 [GeForce GTX 960] driver: N/A
 Display server: driver: loaded: nvidia tty: 160x64
 Message: Unable to show advanced data. Required tool glxinfo missing.

inxi -S:

 Host: pc Kernel: 5.10.84-1-MANJARO x86_64 bits: 64 Console: tty 2 Distro: Manjaro Linux
Currently running: 5.10.84-1-MANJARO (linux510)
The following kernels are installed in your system:
 * linux510

It didn’t say anything about video drivers when you typed in mhwd -li ?

It looks like you don’t have a video driver installed but still have the config.

as far as I know

Device-1: NVIDIA GM206 [GeForce GTX 960] driver: N/A

driver: N/A means the driver isn’t loaded/installed. (perhaps the kernel-module isnt loaded)
But perhaps the gurus here have more useful info.

He might be able to use the same command you gave him before with a -f or --force flag to force it to go through but I don’t know if that could cause other issues.

i ran it again and it says this for

>Installed PCI configs

name: video -nvidia
version: 2021.12.18

alright, i fixed it by installing linux510-nvidia

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.