Remove windows 10 boot manager from GRUB menu?


I had two SSD in my PC one with manjaro and another with windows 10 and I would dual boot between manjaro and windows 10. But I recently removed the SSD from my PC that had windows 10 and when I boot my PC grub still shows the option for windows 10 boot manager. How would I go at removing this?

Thank you

Try sudo update-grub in a terminal.

Missed a step. Remove the EFI boot entry with efibootmgr, then update grub to reflect the change. :wink:

1 Like