Remove Snap from Manjaro (in my particular case)

Hello everyone,
i want to remove all snap packages and snap.

Sorry to ask this question despite the fact, that there are already very similar threads in this board but im very unsure about my specific snaps which are currently installed.

snap list

Name                     Version                     Rev    Tracking       Publisher   Notes
core                     16-2.51.4                   11606  latest/stable  canonical✓  core
core18                   20210722                    2128   latest/stable  canonical✓  base
gnome-3-28-1804          3.28.0-19-g98f9e67.98f9e67  161    latest/stable  canonical✓  -
gtk-common-themes        0.1-52-gb92ac40             1515   latest/stable  canonical✓  -
kde-frameworks-5-core18  5.61.0                      32     latest/stable  kde✓        -

Thats why i have two questions:

1. How to remove snap(s)


it is posted, that i should check if gnome-software-snap or discover-snap is installed (pamac list -i) and first replace it with the non-snap version.
I have none of both installed but there are things like “core”, “gnome”, “gtk” and “kde-frameworks”, installed as sanp sound to me as very important.

So should i just go and type in

user $ pamac remove snapd
user $ sudo rm -r /var/lib/snapd

or is the risk too high?

2. Will it stay like this
Will these changes be persistent or will snap be reinstalled during a future minor or major update of manjaro?


System Information:

System:    Kernel: 5.14.0-0-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 
           wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x serial: <filter> UEFI-[Legacy]: American Megatrends 
           v: 3805 date: 05/16/2018

The guide is correct and should be fine. In pamac, you can disable snap support.
If you don’t want to use any snap packages, you can remove everything. You will not lose anything you need.


Manjaro does not operate like Ubuntu (or Windows). That should not happen.


Nice and thank you guys!

It worked for me and now everything is as clean as i wanted
No snap stuff in lsblk or anything like that

Awsome :drooling_face:

How was it solved? Likely someone else is going to come upon this in the future. Trying to figure out what happen.

Ok basically there was no problem to be solved.
I just was not sure if I break my system as I remove snap.

But the guys helped me out and I just removed it as specified in the documentation

user $ pamac remove snapd
user $ sudo rm -r /var/lib/snapd

Piece by piece I realized, that I did not want to use snap due to the increase of boot time and additional listing of stuff in lsblk etc

1 Like

It’s been a long time I ever used snaps, so not sure, but sometimes there is also a snap folder in your home folder.

If still there after removing snap packages, you can also delete it without risk.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.