Remove Hibernate from log out

How can I remove Hibernate and Hybrid Sleep buttons from log out screen?

Without testing:

→ right click the Whisker-Menu (the menu button)
→ Preferences
→ the 4-th tab (Commands … or whatever it is called in the english translation)
there you can check/select what will be presented and what won’t

1 Like

No, I tried that.
That is only relative to the whisker menu entry buttons and not Log out buttons:

Bit confused. Nothing new. :disguised_face:

Do you mean the ‘Action Buttons’? If so right click / properties.

I mean Remove the buttons Hibernate and Hybrid Sleep from this logout screen:


This might be related to how you have settings in Power Manager (Settings-Power Manager). I do not have hibernate offered with the action button because I have “When hibernate button is pressed Do Nothing” and “When sleep button is pressed Do Nothing” under General Tab in Power Manager.

Also checked that too:

I have Suspend selected:

sudo mkdir -p /etc/systemd/sleep.conf.d/
echo -e "AllowHibernation=no\nAllowSuspendThenHibernate=no\nAllowHybridSleep=no" | sudo tee /etc/systemd/sleep.conf.d/overwrite.conf
systemctl reboot

The buttons still show in the log out menu like the picture above.

Check this:

That worked has intended:

Thanks :+1:

1 Like

The post from bill_t did what I wanted.
Can I delete the config. file your command made?

I’m thinking it’s safe. If you want to test this, just move the file, and test it. If it works, remove the file. If not, restore it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.