Remove 5.4 LTS breaks dependency

Hi. I currently have 3 kernels installed: 5.4 LTS, 5.10, 5.13.

My understanding (hope I’m not wrong!) is that both 5.4 and 5.10 are LTS. I thought I could remove 5.4 since I don’t want 2 LTS versions…I get an error message though when I try to remove 5.4:

checking dependencies...
:: removing linux54 breaks dependency 'linux54' required by linux-lts

I was just trying to free up some space on my boot partition since it’s full; I only have 3 kernels installed (I should have assigned more space to my boot partition when I installed!).

Can anyone advise what I need to do to remove 5.4 or can I not do that?

Thanks,

1 Like

remove linux-lts. it’s only a metapackage, it shouldn’t take anything else with it.

You’re using the manjaro settings manager right? Usually that thing does everything by itself.

Thanks for your responses.

I was using settings manager when I got that message. I have now tried:
#sudo pacman -R linux-lts
checking dependencies…

Packages (1) linux-lts-1:5.4-4

:: Do you want to remove these packages? [Y/n] y
:: Processing package changes...
(1/1) removing linux-lts                                                                             [###########################################################] 100%
:: Running post-transaction hooks...
(1/1) Refreshing PackageKit...

That seems to work but I still see linux54 listed when I do

> mhwd-kernel -li

1 Like

Strange…so I rebooted and then used settings manager to remove the kernel and this time it was successful. I’m not sure why I still had to remove the kernel from settings manager after already removing it from the cli…

You didn’t.
You (just) removed the meta-package linux-lts which had a dependency to linux54 (the actual kernel package).

1 Like

linux-lts and linux-stable are no longer in the repos. You have to select which particular kernel you want (i.e, linux510, linux512, linux513, etc.)

If you use the Manjaro Settings Manager, the LTS and Recommended tags signify which ones to use for those of us who wish to stay on LTS kernels. So rather than relying on a metapackage, you have to manually jump from LTS to LTS when the time comes.