Reinstate "close window with multiple tabs?" warning in xfce thunar file manager?

Hello, can’t find this in a general search, tried preferences in file manager as well, and the Thunar manual xfce:thunar:4.16:preferences [Xfce Docs]. I accidentally clicked “do not ask me again” when I got the “close window with multiple tabs?” warning. How do I reinstate that? thanks

1 Like

open the settings-editor
either via the menu or via terminal like this:

LANG=C xfce4-settings-manager

go to way down, to “Other” - Settings Editor
choose thunar on the left
look for “misc-confirm-close-multiple-tabs”
and set it to “true” / mark it
in the value column on the right
close window

ha! got it, thanks! What happened was originally I was looking for the setting/something related on a different computer where the warning was still active, at that exact area in the list there was no “misc-confirm-close-multiple-tabs”. Went to the problem computer, bingo, there it was, but set to “false”. heh, interesting, thanks again!

I first tried to edit the file
in which this setting is reflected
but editing that had no effect

then remembered the settings-editor …

Nice work, thanks! Beyond updating and a few basic actions most of my forays into the terminal are only when following specific instructions from somewhere, I still prefer a GUI when available but am getting more used to the terminal as time passes.

I just mentioned the terminal and how to start the xfce4-settings-manager through it
so that I could be sure that you and others could find it.

Not everyone might know where to reach it,
my system language isn’t english
so I couldn’t even be sure whether I used the correct name to describe what I meant.
The terminal command is unambiguous, less prone to misunderstandings.

Just curious, you must of had the “close window with multiple tabs” warning already turned off on your machine? Otherwise if still active like my second machine you wouldn’t have seen that setting “misc-confirm-close-multiple-tabs”? Wondering if that wasn’t the case then how did you find out that setting would be there :slight_smile:

I run xfce but I rarely even use thunar.
I saw your query, got curious and tried it - I did what you did and intentionally selected “do not ask me again” to create the issue.
so that I then could find out how to revert it.
… too much time on my hands, I know :wink:

heh, nice! Was wondering if you had some kind of special terminal-fu prowess going on :slight_smile:
Not sure but this little thread and your sleuthing might prove to be useful to others over time, like I said I couldn’t find a peep about it even in the manual. That was a good process you came up with, I’ll keep it in mind!
oh… then again, maybe not much traffic on this… most people would be looking on the problem machine itself unlike me D’OH

I do :wink:
not very special though, not nearly good, but good enough
I know just enough of the basics to know where to look and search to eventually find a solution.

I believe it! thanks again, glad you had some extra time today. 20 years ago warnings like that were an annoying extra click that I would immediately dispense with. Today I make sure they stay in place, the ‘saves’ they provide happen with increasing frequency as I age :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.