Reinstalled Manjaro (Dual Boot) - No Grub Menu Can't Access Windows 10

What’s the easiest way to fix this?

Alright guys update! Fixed the EFI issue:

efibootmgr -v                                                                                                                                                   
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager	HD(2,GPT,bd1620a7-fcb4-443c-9396-38443fd2e290,0xfa000,0x32000)/File(\EFI\Microsoft\boot\bootmgfw.efi)
Boot0001* manjaro	HD(2,GPT,bd1620a7-fcb4-443c-9396-38443fd2e290,0xfa000,0x32000)/File(\EFI\manjaro\grubx64.efi)

Now if I manually select my Windows Boot Manager from my BIOS, I can finally access my Windows 10 installation again (hooray!). However, at this point I thought updating grub would detect my Windows installation, and it appears that is still NOT the case:

sudo update-grub
[sudo] password for aahmad: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Any ideas why / how to get Grub to detect my Windows 10 installation at this point? Thanks again to everyone for your time and help, it is greatly appreciated!

You need os-prober installed to detect Windows in GRUB.

sudo pacman -S os-prober && sudo grub-mkconfig -o /boot/grub/grub.cfg

No good unfortunately. Output:

sudo grub-mkconfig -o /boot/grub/grub.cfg                                                                                                                        
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

And yes, I did the first half of the command to install the os-prober package as well.

It appears os-prober cannot find other operating systems on an NVME drive.

Unrelated, but kernel 5.9 is end of life and will no longer receive security updates. I’d recommend kernel 5.10, which is the next long term support kernel.

So, what are my options at this point? Thanks for the kernel notification, once I get everything squared away, I’ll be sure to switch over to 5.10 for LTS lifestyle.

Have you disabled fast boot in Windows?

So, looks like I currently have fast boot enabled:

What is also interesting is when I try to ‘shutdown’ my Windows 10 install, instead of shutting down the laptop, it just takes me back to the login screen for some reason. Restart works correctly, but shutdown does not actually turn off the laptop for some reason…wonder if this is related to the issue or not.

Fast boot should be disabled in Windows when dual-booting with Linux.


At this point, I boot a windows 10 USB stick into recovery and repair and re-install/fix the windows boot. Just follow the link I posted above to Dell’s tutorial. Once Windows boots again, you can reinstall Grub by chrooting into your existing Linux install.

WHat happens if you force Windows to boot first in the BIOS?

It loads Windows 10 normally, no issues.

Hello: Is grub customizer an option? Search for grub-customizer. I think I used it before on a dual boot box. I know people who have downgraded the bios to the immediate previous edition. Upon “flashing” the bios, manually edit the fast boot option to “disabled”, change the option to “legacy & EUFI”. Make sure USB legacy devices are enabled (don’t want your wireless keyboard to stop working), save and reboot. Good Luck.

@DeLinuxCo - When I run through the Dell steps you posted for restoring an EFI, it gives me some additional errors (clues) on what is going on:

“7. Verify that the EFI partition (EPS - EFI System Partition) is using the FAT32 file system. Assign a drive letter to it that is not already in use.):” I see the following:

Instead of recognizing the volume as a “FAT32” file-system, it is being reported as “RAW”.

And when I try to mount and CD into that volume, I get the following error:

So, it seems like Linux can see this ESI partition (recognizes it is FAT32 and can mount it), but Windows recovery cannot. In terms of options, can I format that partition and reinstall it? Will I lose my ability to boot into Manjaro at that point?

Thanks guys!

@anon59284200 - Thank you I have DISABLED fast boot and it is now shutting down properly on the Windows side.

The RAW partition is your swap partition for linux. Windows does not even show the EFI partition.

GO back into Windows and run through Disk Manager and see what is going on.

As for formatting the partition, it seems it will be more trouble than it is worth. You will loose access to both OS’.

At this point, if it was me, and since you can access both OS’s, back up your data from both and do a clean install on both. Get a fresh start.

NOTE: Grub Customizer should not be used to Manjaro’s version of Grub, it has been known to break grub altogether. Manjaro uses a custom version of GRUB, with the regular GRUB, works great, I use it on my Arch machines.

That’s a lot of work on my end right now (to do a fresh install) on BOTH OS’s. I’m fine with redoing Linux right now (since I barely have done anything on my fresh Manjaro Gnome installation).

Since Linux CAN see the EFI partition, is it possible I can format the (delete) the EFI partition under Manjaro, and recreate it in windows recovery steps? If I “lose” Linux and have to start-over, that’s acceptable…if I have to start-over from scratch with both Windows AND Linux, that’s going to be a pain in the butt.


What information did Disk Manager give you?

Windows “sees” it, but not sure if it recognizes it as an EFI partition:

Windows should say “EFI partition or EFI Disk” or something to that effect. Boot back into Linux, open Gparted and right click on the EFI partition and click “Manage Flags”. “boot” and “esp” should be both checked and nothing else.