Reinstall broken nvidia drivers

  1. Hey, I have followed a guide for installing lutris on my device and I think that It messed up my gpu driver, since my second monitor isn’t detected anymore. I currently have these drivers installed. When trying to reinstall video-nvidiaI get:
> Removing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-utils breaks dependency 'nvidia-utils=530.41.03' required by nvidia-dkms
:: removing nvidia-utils breaks dependency 'nvidia-utils' required by python-py3nvml
Error: pacman failed!
Error: script failed!

Done ...

My optimus-manager isn’t booting anymore either, giving me the error:

ERROR: the latest GPU setup attempt failed at Xorg pre-start hook.
Log at /var/log/optimus-manager/switch/switch-20230424T191657.log
Cannot execute command because of previous errors.

And /var/log/optimus-manager/switch/switch-20230424T191657.log tells me: pastemyst | (untitled)


I used the commands: sudo pacman -S nvidia-dkms nvidia-utils lib32-nvidia-utils nvidia-settings vulkan-icd-loader lib32-vulkan-icd-loader and sudo pacman -S lib32-mesa vulkan-intel lib32-vulkan-intel vulkan-icd-loader lib32-vulkan-idc-loader

What guide?

Temporarily remove those two packages:

sudo pacman -Rdd nvidia-dkms python-py3nvml

Then try reinstalling the NVIDIA driver:

sudo mhwd -a pci nonfree 0300

Once you’re done, you can reinstall python-py3nvml. You normally don’t need nvidia-dkms since you’ll have the precompiled kernel driver installed; i.e., linuxXX-nvidia.

Reinstalling the driver gives me:

sudo mhwd -a pci nonfree 0300
> Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:01:00.0 (0300:10de:1f15) Display controller nVidia Corporation TU106M [GeForce RTX 2060 Mobile]
> Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:00:02.0 (0300:8086:9bc4) Display controller Intel Corporation CometLake-HGT2 [UHD Graphics]
Error: config 'video-hybrid-intel-nvidia-prime' conflicts with config(s): video-nvidia

Remove video-nvidia first:

sudo mhwd -r pci video-nvidia

Thanks, this seems to have fixed it. I rebooted and it works now again!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.