[REGRESSION] v5.14.1 kernel is making rk_gmac to not work

Just a note, v5.14.1 is making all rk_gmac not working.

At least RockPro64 is tested (RockPi4 would mostly be the same), while v5.14.2 fixes it.

It may be better to release v5.14.2 early.

1 Like

Kernel linux-5.14.2-1 is already in the unstable branch. It was pushed yesterday.

Yep, that’s how I got out of the no-working-ethernet problem.

But still hopes the package can be pushed to stable faster, as it’s a pretty bad regression for RK3399 boards.

It’s mentioned in the Known issues section with a workaround, until the next stable update happens.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.