Refreshing databases aur.archlinux.org/packages-meta-ext-v1.json.gz -> TLS support is not available

I’m having problems updating packages. I get the error below. Tried clearing caches in the settings without any luck.

Preparing...
Synchronizing package databases...
Refreshing core.db...
Refreshing extra.db...
Refreshing community.db...
Refreshing multilib.db...
Refreshing core.files...
Refreshing extra.files...
Refreshing community.files...
Refreshing multilib.files...
https://aur.archlinux.org/packages-meta-ext-v1.json.gz: TLS support is not available

https://aur.archlinux.org/packages-meta-ext-v1.json.gz: TLS support is not available

system info

System:
  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=4f70ca2f-14a2-463c-886e-c012f6aad96d rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20KGS95J00 v: ThinkPad X1 Carbon 6th
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20KGS95J00 v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N23ET79W (1.54 )
    date: 10/21/2021
Battery:
  ID-1: BAT0 charge: 38.7 Wh (77.2%) condition: 50.1/57.0 Wh (87.9%)
    volts: 11.7 min: 11.6 model: LGC 01AV494 type: Li-poly serial: <filter>
    status: Discharging cycles: 269
Memory:
  RAM: total: 15.38 GiB used: 6.35 GiB (41.3%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i7-8650U bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1544 high: 1626 min/max: 400/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1479 2: 1571 3: 1626
    4: 1525 5: 1567 6: 1596 7: 1500 8: 1494 bogomips: 33615
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
    hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm
    lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti
    pts rdrand rdseed rdtscp rep_good sdbg sep sgx smap smep smx ss ssbd sse
    sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:3
    chip-ID: 5986:2115 class-ID: 0e02
  Display: x11 server: X.org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15d7 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 02:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:2 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 103.55 GiB (21.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB512HAJQ-000L7 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 5L2QEXA7 temp: 45.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 370.59 GiB size: 363.71 GiB (98.14%)
    used: 103.55 GiB (28.5%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
    label: N/A uuid: 4f70ca2f-14a2-463c-886e-c012f6aad96d
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A
    uuid: 7559-93FF
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 499 MiB fs: ntfs label: Recovery
    uuid: 5E14927514924FBF
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 100 MiB fs: vfat label: N/A
    uuid: 5893-67D8
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 105.24 GiB fs: ntfs label: N/A
    uuid: B60095370094FF93
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2b class-ID: e001
  Device-2: 1-8:3 info: Acer Integrated Camera type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:2115
    class-ID: 0e02
  Device-3: 1-9:4 info: Synaptics Metallica MIS Touch Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 06cb:009a class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-3:2 info: Realtek USB3.0-CRW type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 800mA
    chip-ID: 0bda:0328 class-ID: 0806 serial: <filter>
Sensors:
  System Temperatures: cpu: 65.0 C pch: 57.5 C mobo: N/A
  Fan Speeds (RPM): fan-1: 4090
Info:
  Processes: 274 Uptime: 44m wakeups: 3 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1323 guix-sys: 0 guix-usr: 45
  lib: 1 pacman: 1278 lib: 375 flatpak: 0 Shell: Bash v: 5.1.16
  running-in: alacritty inxi: 3.3.12

Are you sure this is a pacman (and not pamac) output?

Please post the command used as well.

You can try refreshing your mirror list:

sudo pacman-mirrors -f && sudo pacman -Syyu

Sorry, pamac gui. Updated the tag.

I refreshed the mirrorlist from the gui, but ran this command too.
Got the same error, but I notice pacman didn’t give this error, and updating using pacman worked. So it looks like a pamac issue.

pacman doesn’t do AUR which the url clearly hints at…
Updating via pamac should work - this error should be restricted to things concerning AUR.

edit: tags adjusted

The pamac gui now states that all is good and nothing should be done. But the error still shows up in the log.

The problem isn’t the multilib repo, it is the AUR meta archive

Editing the post title

I get another error when searching if that helps

$ pamac search whatever
Failed to query https://aur.archlinux.org/rpc/?v=5&type=search&arg=whatever from AUR: TLS support is not available

Try deleting the file (packages-meta-ext-v1.json.gz ) in /var/tmp/pamac-build- your user name
and give it another try.

Noticed I didn’t have that file. Ran pamac upgrade, and it worked! So something™ probably removed that file, but I have no idea what…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.