Recover data from corrupted XFCE ARM

Hello guys. I run a server on Manjaro ARM Linux, and recently the power went out. Now the OS is corrupted and the system won’t boot. This is a problem, because I REALLY need to get the data off of it.
Honestly I’m lost and I have no idea what to do. Help me please :confused:

I’m pretty sure I use XFCE ARM, but I don’t know for sure and there’s definitely no way of telling now.

You provide no details about your server, so this is what I would try. Boot from an external USB with Manjaro installed - even the live cd could do that. Now mount the root directory of your server (or just the /home directory if that is where the data is) and copy your data off to an external drive that can store it.

Hope this helps!


Hi, the server is a Raspberry pi 4. I will try this, but I have another question. Isn’t it weird that on loss of power, the os gets corrupted? Because it does that almost everytime when power stops. And is there a way to stop it from happening again?

Please have a look at:
free advice for raspi and sd

SD do wear out, they are not the best thing for long term usage for needed data. It could be the SD was about toast before the power outage. Not much to protect against a failing SD.

Use cronie or a systemd timer to rsync required data to another server to keep a copy online and accessible (or maybe to an attached usb storage device).

I would try to copy the required data first, prior to performing filesystem repairs, sometimes that can make matters worse for accessing data on failing media. If successful, then try it again after performing a fsck.

For a future SD, you might try under-provisioning, by not partitioning the entire SD, leave 10-20% un-allocated space. The easiest way is to use dd to copy the SD to a larger SD, or you could put the SD in another computer and shrink the partition after first boot with gparted. It sort of depends on what hardware you have available to you for these gyrations.

The sd is only half a month old and still has quite some space available. It still works, it’s even being picked up by my laptop, but I have no clue what files to look at, and they are also in weird .[something] files

I can’t open that

I’ve moved it out of that area of fourm.

Take the SD card out of the raspberry Pi. Put it into a SD card reader for your PC (could be a USB adapter) and plug it into a regular Linux box.

Open your File Manager on the linux box, go to the mounted destination of the SD card’s partitions and start copying files of it.

1 Like

I realized I had a very old Linux Mint laptop laying around so I plugged it in there. This worked. Thanks so much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.