Recent Update broke Steam, is there a fix underway?

Dear all,

the most recent Updates seem to have broken Steam for various people. I am making a new thread because I cannot be sure that this is related: Steam is not starts and not working

After updating, Steam immediately closes with a segmentation fault and no further errors. A gdb stacktrace reveals the following:

#0  0xefdd9474 in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#1  0xefdd7c0d in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#2  0xefdc8b43 in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#3  0xefdcff64 in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#4  0xefd90c6e in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#5  0xefcd53d6 in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#6  0xefcf043b in SDL_InitSubSystem () from /home/adrian/.local/share/Steam/ubuntu12_32/
#7  0xede2d362 in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#8  0xede7078c in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#9  0xede7fbff in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#10 0xf24ca81a in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#11 0xf19e442e in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#12 0xf1b0cd58 in ?? () from /home/adrian/.local/share/Steam/ubuntu12_32/
#13 0x5659ec99 in ?? ()
#14 0x5659fbae in ?? ()
#15 0x56589b30 in ?? ()
#16 0xf7b82119 in ?? () from /usr/lib32/
#17 0xf7b821ed in __libc_start_main () from /usr/lib32/
#18 0x5658e9f5 in _start ()

This happens with both steam and steam-native-runtime, even after a steam-runtime --reset and after forcibly removing the folders .steam and .local/share/Steam from my home. Funnily enough, even the Steam Flatpak from Flathub crashes with the same error.

Has anyone found a fix yet?

Best regards

To me it looks like an issue where steam has not caught up with current state of libraries.

That’s what I figured, which is why I have no idea how to fix it. I forgot to make a timeshift snap before the update. Am I stuck in this unusable state now until the Steam devs push an update?

flatpak - as I understand - is a self contained package that works without system dependencies - other than flatpak runtime.

As you mention flatpak is affected as well - I suspect it is an issue with the core steam libs - in which case you are likely correct - you will have to wait.

Bit of a shot in the dark.

pamac search --files /usr/lib32/                                                                                                                                                          
/usr/lib32/ is owned by lib32-glibc

There might be an issue with the local package as this post has as a solution.

Sadly, I had already found that thread and consequently done a pamac reinstall lib32-glibc, with no change. Or is a reinstall not enough?

1 Like

Don’t think its any help to you but I just installed the steam update and steam seems to be running ok. I am on the testing branch though so could be the difference

[sawdoctor@sawdoctor-gs726qe ~]$ /usr/bin/steam-runtime %U[81946]: Running Steam on manjarolinux 22.0.1 64-bit[81946]: STEAM_RUNTIME is enabled automatically[82020]: Steam runtime environment up-to-date![81946]: Steam client's requirements are satisfied
[sawdoctor@sawdoctor-gs726qe ~]$ 

Did you guys try to update/change libsdl2-2.0-0 :thinking:
On my Kubuntu system: (don’t have Steam installed yet)

dpkg-query -S libSDL2
libsdl2-2.0-0:amd64: /usr/lib/x86_64-linux-gnu/
libsdl2-2.0-0:amd64: /usr/lib/x86_64-linux-gnu/
libsdl2-2.0-0:i386: /usr/lib/i386-linux-gnu/
libsdl2-2.0-0:i386: /usr/lib/i386-linux-gnu/

Steam bundles its own version of libsdl2-2, it does not use the system implementation. Both steam and steam-native-runtime seem to select the version shipped with Steam.

Just for fun, I tried installing libsdl myself, and I do get a different (newer?) version than the one shipped with Steam, but if you try to trick Steam into using it by copying over, it will fail the checksum verification at startup and download the Steam one again. If you prevent the download, it refuses to start. Unless someone knows a way to make Steam skip the installation verification at startup, I see no way to even test whether a different library would work.

Strange, even when Steam does work, I get a lot more output than what you get.

Update: I have just noticed that VLC media player also segfaults when trying to play any video. The stacktrace seems to suggest that glibc6 is to blame, since it issues the fatal call both for Steam and VLC.

#0  0x00007ffff3ce88b4 in XDisplayString () at /usr/lib/
#1  0x00007fff94f77a1d in __vaDriverInit_1_13 () at /usr/lib/dri/
#2  0x00007fffb6eb49c3 in  () at /usr/lib/
#3  0x00007fffb6eb7cd0 in vaInitialize () at /usr/lib/
#4  0x00007fff94f827d3 in  () at /usr/lib/vlc/plugins/video_output/
#5  0x00007ffff7ca269f in  () at /usr/lib/
#6  0x00007ffff7ca55f4 in vlc_module_load () at /usr/lib/
#7  0x00007fff9c05a054 in  () at /usr/lib/vlc/plugins/video_output/
#8  0x00007fff9c05e21d in  () at /usr/lib/vlc/plugins/video_output/
#9  0x00007ffff7ca269f in  () at /usr/lib/
#10 0x00007ffff7ca55f4 in vlc_module_load () at /usr/lib/
#11 0x00007ffff7d3d1b1 in  () at /usr/lib/
#12 0x00007ffff7cf810b in  () at /usr/lib/
#13 0x00007ffff7cfb377 in  () at /usr/lib/
#14 0x00007ffff7e0b8fd in  () at /usr/lib/
#15 0x00007ffff7e8dd20 in  () at /usr/lib/

Yet another update: I have confirmed that this is triggered by the Jan 19 update of the nvidia graphics drivers. Switching to the free drivers solves the problem (while causing the usual problems of the free drivers, thereby not being a long-term alternative).