Realtek Semiconductor Co., Ltd. Device [10ec:b852] not working on Manjaro KDE

I recently installed Manjaro KDE on my Asus TUF Gaming laptop and everything seems to be working fine except for the Wi-Fi. The Wi-Fi adapter is detected but I can’t seem to get it working. The adapter is a Realtek Semiconductor Co., Ltd. Device [10ec:b852].

I’ve tried installing the rtl8822ce-dkms-git package but it didn’t work. I’ve also tried installing the linux-lts-headers package as suggested in some forums but it returned an error saying that the target is not found.

I saw someone with the same laptop and Wi-Fi adapter as mine running Ubuntu and had the same issue but was able to fix it by installing the rtl8822ce-dkms package.

Does anyone have any suggestions on how I can get my Wi-Fi working on Manjaro KDE with this Wi-Fi adapter? Any help would be greatly appreciated.

Thank you!

According to this:
" The device is supported by kernel versions 6.2 and newer"

So, try installing kernel 6.2 or 6.3. You’ll have to use some alternative method (cable for example) to connect to Internet

1 Like

Isn’t it risk to change the kernel? Is there a tutorial I could follow?

It’s not a risk at all. Open KDE settings, find the “Kernel” section in the sidebar (added by Manjaro), install 6.3 and restart.

1 Like

This driver may be worth giving a try:

It is available via the AUR via pamac GUI or in terminal (requires dkms)

pamac build rtw89-dkms-git

@jrichard326 The driver you linked is already present in kernels 6.2 and newer, as the previous post said. Newer kernels often include patches for improved filesystem performance too.

I would recommend linux63 as linux62 will be end of life shortly.


Ok thank’s, i installing kernel 6.3 and it’s ok !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.