Realtek RTL8812AU Wireless Adapter Woes

Okay. So, I got an Alfa wireless usb adapter for…reasons… and though it got rave reviews, I cannot get the darn thing to install at all. The chipset in it is an rtl8812au. I’ve installed and removed every driver on github, AUR and pamac for it, and nada. The thing installs in Kali as easy as plugging it in and typing a single command. In Manjaro, I’ve typed pages of commands, all seemingly successful, but they don’t appear to do the job. Now, I’ve just installed Manjaro fresh due to an unrelated problem, and I’ve done a single install on my wireless adapter by following a tutorial from a Manjaro forum: Install rtl8812au-dkms-git driver
It went well, but didn’t work. I followed instructions to the letter (I’m a chemist, I can do that). The end of the article had a half dozen commands to run and report back with, and I have those if needed.
So, I then thought maybe I just had to switch the adapters out, and followed this tutorial: How to switch between internal and external wifi adapters
Again, did not work (keep in mind the state of the original driver is likely not normal from following the commands in that tutorial). And yes, I know the unit is good, because I dual boot Kali and it performs as advertised there. So, here is my inxi, and I will eagerly await advice from those more knowledgeable and wise than I. Oh, and I know it says I’m on kernel 5.9.16, but I’ve installed 5.11 a few times and that doesn’t change:

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=5c08e2d1-a160-41f5-b139-94db75a541d0 ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: OMEN by HP Laptop 15-dc0xxx v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 84DB v: 93.21 serial: <filter> UEFI: AMI v: F.12 
  date: 03/23/2020 
  RAM: total: 15.52 GiB used: 2.49 GiB (16.0%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: DE L2 cache: 9 MiB bogomips: 52815 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Hewlett-Packard 
  driver: nouveau v: kernel alternate: nvidia_drm,nvidia bus ID: 01:00.0 
  chip ID: 10de:1c20 class ID: 0300 
  Device-2: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo 
  bus ID: 1-6:4 chip ID: 0408:5300 class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3599x1080 s-dpi: 96 s-size: 949x285mm (37.4x11.2") 
  s-diag: 991mm (39") 
  Monitor-1: eDP-1 res: 1920x1080 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  Monitor-2: HDMI-1 res: 1680x1050 hz: 60 dpi: 90 size: 474x296mm (18.7x11.7") 
  diag: 559mm (22") 
  OpenGL: renderer: NV136 v: 4.3 Mesa 20.3.4 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 class ID: 0403 
  Device-2: NVIDIA GP106 High Definition Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
  class ID: 0403 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:a370 class ID: 0280 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 3c:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-3: Realtek Realtek 8812AU/8821AU 802.11ac WLAN Adapter [USB Wireless 
  Dual-Band Adapter 2.4/5Ghz] 
  type: USB driver: usb-network bus ID: 1-2:2 chip ID: 0bda:0811 
  class ID: 0000 serial: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus ID: 1-14:5 chip ID: 8087:0aaa class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 5020 bus ID: 00:17.0 chip ID: 8086.282a rev: 10 
  Local Storage: total: 1.15 TiB used: 42.84 GiB (3.6%) 
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SD08G size: 7.52 GiB block size: 
  physical: 512 B logical: 512 B rotation: SSD serial: <filter> scheme: MBR 
  SMART Message: Unknown smartctl error. Unable to generate data. 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLW256HEHP-000H1 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: CXB73H1Q temp: 35.9 C 
  scheme: GPT 
  ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000BX500SSD1 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 030 scheme: MBR 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 48.83 GiB size: 47.81 GiB (97.92%) used: 13.76 GiB (28.8%) 
  fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4 label: root 
  uuid: 5c08e2d1-a160-41f5-b139-94db75a541d0 
  ID-2: /boot raw size: 1.94 GiB size: 929.8 MiB (46.82%) 
  used: 70.2 MiB (7.5%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-2c1f875d-9525-42a3-ad0a-bceee4f5ae43 label: N/A 
  uuid: 0547e253-446b-454d-a046-890434596dca 
  ID-3: /boot/efi raw size: 2.93 GiB size: 2.92 GiB (99.80%) 
  used: 588 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: EFI 
  uuid: D4C9-0B25 
  ID-4: /home raw size: 168.73 GiB size: 165.08 GiB (97.84%) 
  used: 29.02 GiB (17.6%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 
  label: home uuid: 3be7ebf8-e26f-48c8-8e46-f4f594403f3d 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: 37aed73a-289f-4557-8b51-1183c73576a7 
  ID-1: /dev/mmcblk0p1 maj-min: 179:1 size: 7.51 GiB fs: vfat label: N/A 
  uuid: 0403-0201 
  ID-2: /dev/sda1 maj-min: 8:1 size: 372.53 GiB fs: btrfs label: ROOT 
  uuid: b7d47726-02ad-45a5-8e52-494fc94e5492 
  ID-3: /dev/sda2 maj-min: 8:2 size: 1 KiB fs: <superuser required> label: N/A 
  uuid: N/A 
  ID-4: /dev/sda5 maj-min: 8:5 size: 29.8 GiB fs: swap label: N/A 
  uuid: f7af76d5-2347-4fca-a075-d11554d5dd26 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 1-2:2 info: Realtek Realtek 8812AU/8821AU 802.11ac WLAN Adapter 
  [USB Wireless Dual-Band Adapter 2.4/5Ghz] 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.1 speed: 480 Mb/s 
  chip ID: 0bda:0811 class ID: 0000 serial: <filter> 
  Device-2: 1-3:3 info: Razer USA RZ01-0321 Gaming Mouse [DeathAdder V2] 
  type: Mouse,Keyboard driver: hid-generic,usbhid interfaces: 4 rev: 2.0 
  speed: 12 Mb/s chip ID: 1532:0084 class ID: 0300 
  Device-3: 1-6:4 info: Quanta HP Wide Vision HD Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 0408:5300 
  class ID: 0e02 serial: <filter> 
  Device-4: 1-14:5 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 8087:0aaa class ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 59.0 C mobo: N/A gpu: nouveau temp: 47.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 286 Uptime: 45m wakeups: 1 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 Packages: pacman: 1522 lib: 435 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: terminator inxi: 3.3.01 


dkms status

shows this:

rtl8812au,, 5.11.1-1-MANJARO, x86_64: installed
rtl8812au,, 5.9.16-1-MANJARO, x86_64: installed

Thanks in advance!

I have absolutely no idea about the rest of your problem, but I suspect you just haven’t booted into the newer kernel yet.

To do so, press Esc right after the “Press to enter BIOS” message. This will bring up the grub boot menu.
Navigate to the Advanced options, where you will see the other kernel.
Select it to boot into it. When successfully booted into it, you can remove version 5.9 from the terminal:

sudo mhwd-kernerl -r linux59

Maybbe this even works for your wifi, who knows? :man_shrugging:

But, either way, I hope it helps!

1 Like

Cool! There I go, I’ll report back!

Well, I tried. never did see a “press to enter bios” message. But, I went through all the boot managers and couldn’t find anywhere to access the kernel. I even tried the grub command line, but it wasn’t liking the command at all. So, no go.

What’s the output of:

mhwd-kernel -li

To choose a different kernel to boot, access the GRUB menu by either holding Shift or tapping Esc.

1 Like

The GRUB menu (where you navigate using your Up and/or Down) IS where you have to select the Advanced options, though.

I’m very sorry I couldn’t help more.

1 Like

Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:

  • linux511
  • linux59

Okay, I use that every day for boot options, but there isn’t an advanced option on mine. I’ll go look again.

Well, the good news is I got linux511 installed and Linux59 removed. The bad news is I can’t boot manjaro anymore, and my journalctl is riddled with errors I don’t know how to handle. Now what?

oh, so, one has to run

mhwd-kernel -i linux511 rmc linux59 

To install the new kernel and remove the old simultaneously. This is done while in the OS. Then, you just boot normally and leave the advanced menu alone. Though, ill have to use it now since I can’t boot.

Without the errors it’s impossible for us to know what next.

However, I’d recommend the following:

  1. Download a new ISO, burn it to USB, and boot from it.
  2. When in the live environment successfully, open a terminal.
  3. Once the terminal is open, run enter a chroot environment of your installation by opening a terminal and running
manjaro-chroot -a

(NOTE: I do not have Windows, so if you do, I don’t know if there’ll be any extra steps to take.)

Be careful from here on, as you are now root.

  1. Once inside chroot environment, you can see which linux kernels are installed and manipulate them as per normal. So enter the following to find out which kernels are installed:
mhwd-kernel -li
  1. You’ll be provided with a list of kernels. For example, I have Kernel version 5.4 and 5.10 installed:
$ mhwd-kernel -li
Currently running: 5.10.18-1-MANJARO (linux510)
The following kernels are installed in your system:
* linux510
* linux54
  1. If you have any DKMS modules installed, you’ll have to reinstall them again.
    For every kernel installed, uninstall it. For example, if I wanted to uninstall kernel 5.4 from the list above, I’d run:
mhwd-kernel -r linux54
  1. Do that for every kernel.
    Do not reboot after this, as your PC will not boot. If something happens, reboot back into the live ISO environment and manjaro-chroot -a again back to this step.
  2. Once all the kernels are removed, reinstall kernel 5.4 again.
mhwd-kernel -i linux54

This is to get a booting system again. If you wish, you can also install kernel 5.11 here:

mhwd-kernel -i linux511
  1. If successful, exit from the chroot environment/
  2. Hold your thumbs, cross your heart, forget my nick and reboot.
  3. At the GRUB screen you should now see an option for advanced…stuff. If you navigate to it, you should, theoretically see options for both the kernels. Choose 5.11 and see if it works.
    5.4 is now your backup kernel for if something goes wrong, then you can always go back to 5.4 and try to sort out your problems.

This may or may not work. I haven’t got the foggiest of ideas. It is, however, how I would’ve tried doing it. I take no responsibility if something goes wrong, I plead innocent! Wasn’t me! If however, it works, well, then heap on the praise! And bring out the party hats! :partying_face: :partying_face: :partying_face:

Edit 2:
While I’m sure it’s reliable, I’ve never run mhwd-kernel -i with the rmc option. Simply because I want to be in control. This way I know more of what’s actually happening and I don’t have to guess what’s going on. So can’t comment on that.

sorry, it was 4am I needed a nap. Kernels are Uninstalled. I’m guessing you were using 5.4 because it is very reliable? I will proceed as Advised and report back. Thank you, again.
Also, the process seems to have also removed the multilib, core, extra, and community databases. So, i might be a bit.

I use 5.4 because it’s an LTS version. (Long Term Support)
And it’s cool, take your time!


According to this page:

You can update the Pacman database cache with the following command:

$ sudo pacman -Syy

So, hope this helps!

Ugh. Dependency conflicts in zfs-utils files are preventing me from installing another kernel. I don’t understand why this is a problem now. I’m gonna do what I can. What’s the deal with real time kernels?

Totally did that :slight_smile:

According to wikipedia:

RTLinux is a hard realtime real-time operating system (RTOS) microkernel that runs the entire Linux operating system as a fully preemptive process. The hard real-time property makes it possible to control robots, data acquisition systems, manufacturing plants, and other time-sensitive instruments and machines from RTLinux applications. Despite the similar name, it is not related to the Real-Time Linux project of the Linux Foundation.[1]

So, in short it’s not for home use. And I don’t understand either.

Ah, sounds like something I’d install just to see what happened. Hey, I do have the journalctl log, if you were curious. I didn’t know how best to include it in a forum thread.

1 of 2 ways:

  • Use a service such as pastebin and provide the link here, wrapping it in single backticks/apostrophes (`) for us to work better with; or
  • paste in here, in the thread wrapped in triple backticks/apostrophes (```), which formats the displaying of it for legibility.

But I’m off for the day. Good luck and thanks for all the fish!

1 Like

You too.

Didn’t work. As a matter of fact, once I got to GRUB, it only showed me the kernel I already removed…