Really bad performance in CS:GO for no apparent reason

I upgraded the Hardware of my Computer yesterday and since then I get about 20 FPS in CS:GO and only CS:GO, everything else I’ve tried runs great.
With MangoHud I can clearly see that CS:GO is using my GPU, with about 30% GPU usage, but only about 7% CPU usage.

I’ve already tried this launch command “mangohud %command% -high -threads 4”.

My hardware before upgrade (Intel NUC Kit NUC6i7KYK with egpu connected):
CPU: Intel Core i7-6770HQ
GPU: NVIDIA GeForce RTX 3060
Memory: DDR4 32GB

My hardware now:
CPU: 12th Gen Intel i7-12700K (20) @ 5.000GHz
GPU: NVIDIA GeForce RTX 3060
Memory: DDR4 16GB

Kernel: Linux 5.15.72-1

pamac install gamemode
systemctl --user enable --now gamemoded.service

Startup option:

gamemoderun mangohud %command% -high -threads 4

Seems to help a little with my problem, now I get around 25 - 30 FPS and CPU usage is around 5%

Hi @Moyme, and welcome!

This might be it. There is a problem with the driver for this card:

To confirm, please provide the output for:

mhwd --listinstalled

Tip:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

```
pasted text
```

This will just cause it to be rendered like this:

Sed
sollicitudin dolor
eget nisl elit id
condimentum
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

1 Like

Output:

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-modesetting            2020.01.13                true            PCI
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI


Warning: No installed USB configs!

Seems that it possibly is. Please provide the output for:

mhwd --list

Output:

> 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


> 0000:01:00.0 (0300:10de:2503) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:00:02.0 (0300:8086:4680) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Ah well… guess you run csgo on you internal GPU which is intel…

Try this to use the nvidia card:

prime-run gamemoderun mangohud %command% -high -threads 4
2 Likes

That fixed it! Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.