Read-only system on root partition after on kernel linux59

Hi everybody!

After restarting my computer I realized that I can’t create or delete anything on my root(/) partition but I can on the others that I use for data. Some applications like terminal can open but other like chrome or Vscode cannot.

In my terminal I realize (by zsh output) that I’m on Linux 5.9.11 and on read-only file system

I was using the linux54 kernel and I guess my latest update, installed the Linux59 kernel

I tried to switch back to linux54
mhwd-kernel -li
I got linux59, 59-rt, 58, and 57 ( same on the grub advance startup )

When I tried to install linux54 ( mhwd-kernel -i linux54) I get read-only system error ( could not read db ´community’ truncated gzip input)

When I even tried to update the system I got a failed to update core ( unable to lock database) error

Besides, I can restart the system properly and login but i can’t run any app on create a file on the / partition means my home also is frozen.

Thanks in advance for any help.


There was never a time when as user (even an admin user) to be able to create/modify/delete files and folders by default in the / (/root partition), without the administrative password. As root was possible.

That is because another instance of the “updater” was running and didn’t finished, and most likely that also lead to an error to install another kernel …

That only happens if you mess with permissions …
If you can’t access terminal, switch to TTY with Ctrl+Alt+F3 for example and run this commands as your user:
sudo chown -R $USER:$USER $HOME
and then
sudo rm /var/lib/pacman/db.lck
followed by
sudo pacman-mirrors -f5 && sudo pacman -Syyu

Those are EOL kernels and you can safely remove them.

Thank you so much for your quick reply

I totally agree with you. What I mean is the whole big partition / including all the files and directories, including /home etc…

I did it but I’m still getting the read-only file system error

This happened when I try to remove Linux58 or 57

If you did not mess with the /etc/fstab file then try to boot in runlevel 3 … add 3 after the rw as replacement of quiet in the linux line


Login as root and try the update that way. Also might want to run:
fsck -f /
before that. If you get the lock database error, run this command also as root
rm /var/lib/pacman/db.lck

Sorry my question might sound stupid for you but how can I run that? :sweat_smile:

I have a GNU grub version 2.04~manjaro

While in BOOT Grub Menu you press e to edit it, then you use the down arrow key to get to the linux line, replace quiet with 3 and then you press F10 to save and continue booting. Once in that TTY you log in as root and then run the commands i mentioned.

1 Like

It woks Thank you so much

1 Like

Now I’m really curious about what happened. Can you explain more please ?
Is it about the linux59 ?

Probably an unwanted partial update. A log might reveal more details about, but i usually avoid chasing that road as it can also give way too much information to check up. :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.