Read-only Hard Disk

Hello everyone,
I’ve tried following several guides for this problem, and I still couldn’t solve it as you can imagine.

I have a hard drive that I use for back-ups, currently while trying to pass material it tells me that it is impossible because it is read-only.

I’ve tried changing the permissions but it won’t let me, I’ve tried passing the folder to root privileges but it doesn’t work.

Do you have any ideas?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  1. You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
1 Like

Try remounting from the terminal, and check for any error that may explain the read-only mount.

Is this an NTFS formatted drive?

Did you try changing the permissions/ownership via the terminal or file manager? Did you use sudo when you tried it?

Please, provide more information.


1 Like

If the device is using NTFS and is in a readonly state the most likely cause is a Windows setting - Fast startup or hibernation. Reboot to Windows and issue a clean shutdown.