RDP on Manjaro GNOME

When running e.g. xrdp on GNOME 40.4 (so the newest available version) it is not possible to establish a connection.
After days of searching the internet I am still not able to connect to Manjaro GNOME via RDP.

I’ve tried everything you can find on Google.
For example:

  • possibly every XRDP guide
  • changing various config files and scripts
  • reinstalling GNOME
  • different kernel versions
  • etc.

When removing “–exit-with-session” from .xinitrc I at least get the “Oh no! Something has gone wrong.” GNOME error message.

So does somebody know how to get an RDP server working on Manjaro GNOME?
It works on Manjaro KDE, so it’s not a problem with Manjaro, it also works with Ubuntu etc., so it’s not a problem with GNOME.
How is it possible?
Or if it isn’t possible, why not?

Welcome to the forum!

Because, unless I would be mistaken, Manjaro GNOME uses Wayland as its display server, and Wayland isn’t network-transparent. You’d have to switch out Wayland for X11.

(I cannot help you with that, because I use neither GNOME nor Wayland. I am only offering up an explanation. :wink: )

1 Like

According to the gnome wiki Gnome supports a RDP server. (never used it, so cannot speek from experience) If not installed on your system, install the package gnome-remote-desktop as that seems to be missing if there are no options in settings for it. If using xrdp, check out the arch wiki page for it.

Yes, Manjaro uses Wayland by default, but X11 is also installed.
Logging in with X11 works just fine.
Also again Ubuntu 20.10 or Fedora 35 also use Wayland but XRDP works there.
So the problem must be somewhere else.

I have gnome-remote-desktop installed.
It makes connecting via VNC possible, RDP is - according to the logs - not configured.
Also there are no docs about configuring the RDP server for gnome-remote-desktop.

I’ve read the official arch wiki page for xrdp and tried everything. It just explains how to setup an XRDP server. But the problem is not with the RDP connection but with GNOME. The wiki does not mention anything about that.

Thanks, though.

Did some testing on a gnome & windows virtual with the package I mentioned. (Github) There is almost no documentation that I can find and understand tho. When staring freerdp-shadow-cli -auth (to test without authentication) a service starts and can be connected to, the windows mstsc client complains about valid certificates. The ‘server’ complains about:

[ERROR][com.freerdp.channels.audin.server] - WTSVirtualChannelQuery failed
[22:20:58:656] [4632:4636] [ERROR][com.freerdp.core.transport] - BIO_read returned a system error 104: Connection reset by peer
[22:20:58:656] [4632:4636] [ERROR][com.freerdp.core] - transport_read_layer:freerdp_set_last_error_ex ERRCONNECT_CONNECT_TRANSPORT_FAILED [0x0002000D]
[22:20:58:656] [4632:4636] [ERROR][com.freerdp.client.shadow] - Failed to check FreeRDP file descriptor
[22:20:58:656] [4632:4643] [ERROR][com.freerdp.channels.rdpgfx.server] - WTSVirtualChannelRead failed!
[22:20:58:656] [4632:4643] [ERROR][com.freerdp.channels.rdpgfx.server] - rdpgfx_server_handle_messages failed with error 1359

And the client complains about a protocol error after showing a second of screen.

I understand your issue, there seems to be no simple way.

This is something that might be a solution but I’ve not tried it.
Edit There is a open issue for RDP support in Gnome-remote-desktop here

gnome-remote-desktop supports RDP and it’s working just fine if setup right. But gnome-remote-desktop is just able to share the screen. Xrdp creates a new session without using the monitor. That’s what I wanted to archive.
Maybe it will work in the future.

check out Open source XRDP server availible in Manjaro AUR repo:

it creates a session on Manjaro x11rdp.

I found a solution: GitHub - txhx38/manjaro-gnome-xrdp: How to get XRDP running on Manjaro GNOME.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.