RaspPI 4b after 5.15.43-1 update mouse is glitching badly

I’ve noticed that right after the rolling of the latest update by May 31 2022 the mouse had started to behave strange, lagging a bit incorrectly following to the actual pointer position. That is a frustration by far specifically for me using the OpenCAD whatnot. Until this I’ve never ever experienced no issues with the periphery. It’s a stock Raspberry Pi proprietary mouse wired and so on. CPU is BCM2835 (4) @ 2.100GHz Mem 1618 Mib/ 7821Mib Plasma 5.24.5 Kernel 5.15.43-1-MANJARO-ARM-RPI Please help!

1 Like

I have the same problem with a raspberry PI400 with a bluetooth mouse

See

Confirming the solution (however temporarily) for specifically my architecture above is in editing of /boot/config.txt
change the line dtoverlay=vc4-fkms-v3d to dtoverlay=vc4-kms-v3d-pi4 .

1 Like

Changing fkms into kms will stop the Rpi4 from booting.
Please correct this by the Software Manager. (XFCE)

You have not provided an info with your setup there so I can only go by what I know. There was a reason why we had released our images with FKMS by default. Some monitor’s/tv’s do not play well with KMS with the kernel setting up your display settings. The problem gets more complicated if using some type of inline video adapter. RPi has discontinued support for FKMS.

Sometimes manual specifying the video parameters in cmdline.txt works for some and sometimes not. You might be able to use llvmpipe as a renderer while you experiment with the various manual config’s.

Install needed package:

sudo pacman -S xf86-video-fbdev

Make needed changes in config.txt(Be sure to comment out any mention of FKMS/KMS):

gpu_mem=512
 
#dtoverlay=vc4-kms-v3d
#max_framebuffers=2

Reboot for changes to take affect.

Thanks,

this solved the mouse issue, but does not support a higher resolution than 1920x1080 which looks not good on a wide screen with 3440x1440 pixel.

The manjaro XFCE Display settings only offer 1920x1080.

Any tips?