RaspberryPI (4b) and RTC solution


Just curious if anyone has a favorite solution. I’m considering several. My problem is that I use the RPI-4 as one of my DNS servers. Whenever the power drops out (frequent here in storm season) when it comes back up it’s usually March of last year. Bind won’t resolve names if the system clock is way out of sync, not even to allow the system to find the ntp pool so it can sync.

Again, looking at a few options, curious if anyone else has had to deal with this and has found a reliable solution…

Kind regards

don’t know about accessories for the 4, but I have a ds3231 RTC module with a battery backup on my 3B…

Cool! I was looking at either that or the PCF8523. They share the same connection configurations. Are you happy with it? Does it work well for you??

BTW, I think most of these hardware devices are pretty Pi-universal, as long as there’s kernel support for whatever. The 4b all the way down to the RPI-b support these.

Works fine for me; the caveat being that I run Buster on my RPi-no interest in Arch (or any derivative)-ARM.

Shouldn’t be a problem for me. I run nothing from the Debian camp, including RaspberryPi OS, Raspbian, or whatever they call themselves. I’ve been a UNIX/Linux/Android C/C++/Java with scripting^10 for the last 25 years. Shouldn’t be a problem in that venue for me. If the device is solid and the docs are clear, I’ll make it happen…

Hmm - I run a bind service on a pi - a very old one - armv6l arch - :grin:

If your system is systemd based using the timesync service usually works.

systemctl enable --now systemd-timesyncd

Another option could be timedatectl-restorer which has a custom script at AUR (en) - timedatectl-restorer

Not Manjaro on the RPi-4b. Switched back to Chronos just to regain some sanity. When the system time gets too far behind, Bind9 (named) can’t resolve names - not for even the ntp pool. I’m not sure what’s changed since the good ol’ OpenSolaris days, but all of this stuff used to be a no-brainer. Now we have resolvconf.d that controls resolv.d ( at least it’s files) and seems like we’re trying more and more every day to be like Microsoft Windows. I’ve got a PCF8523 on the way. Should fix the issue. Also have a RTC battery and harness coming for my Odroid XU4 (my secondary DNS device) so between the two of them, they’ll sort things out after the power comes back up.

TBH: There are many things I’ve grown to love about systemd. They’re very much akin to the older Solaris service orientations and commands ( svcadm… etc), yet there are things I’m growing to hate and that are about to drive be back to FreeBSD.

Thanks all for your thoughts though. Much appreciated!!!

timedatectl-restorer - bricked me once. Won’t do it again assuredly.

Truthfully, I’m about to be done dinking around with these credit card ARM boards and get a couple mini PCs (RYZEN). I won’t have to power up the big girls (both sporting hardware RAID-5, 32G, Piledriver CPUs and loving to suck a whole lot of electricity)
The RPi has been fun to fiddle with, but at the end of the day it’s been such a nuisance.

I’ve got a couple Atmel 8bit AVR microcontroller projects coming up I need to focus on soon anyway. Won’t have time to fiddle with this junk.