Raspberry pi not allowing ssh connections

I am trying to connect to my pi through ssh, but I am getting No route to host error when opening the connection. Furthermore, when trying to ping the pi’s ip I am also getting Destination Host Unreachable multiple times. However, on my pi I have perfect internet connection and can even ping my pc’s ip successfully. To confirm, I have ran multiple ping tests on multiple servers and it works just fine on both my pc and my pi.
I have tried installing openssh, enabling it with systemctl and then starting it, however I am still receiving the same error messages.
Note that ssh has worked for the past year flawlessly and I am suddenly getting problems out of the blue. Also note that I cannot change anything in the gui due to my pi being a minimal server.

Are you sure of the pi’s ip? All the information you have given does not exclude this possibility.

See this how-to about basic network checks on this forum : [root tip] Basic network know-how The check using the arp-scan command should give you some insight into the devices on the network.

Unless the pi’s ip would of changed overnight…yes

Okay, so I checked the ip and it changed. I’m really confused how this happens, but the good news is that I can ssh into the pi with the new ip. What caused the ip to change? ps the original was and its changed to

Sometimes this happens because of a firmware update of the modem/router or a reset or a power failure.

When you expect a device providing a service to be available on an specific IP you need to ensure the device get’s the IP after device restart or network restart.

A default network assigns addresses dynamically when devices come and go by a DHCP service. The address is bound to the interface mac address. The service is usually a part of the router.

The service uses a lease time which is defined in service settings. If the lease has expired the address can be assigned to any device if the previously assigned device is not visible on the network.

There is two methods to ensure the same IP is always assigned to a specific mac address.

The easy method

If the router provides the option you can configure the dhcp service to always assign a specific IP to a specific hardware address (mac).

The nerd method
This method requires you to know the scope or range of address used by the dhcp service as you must choose an address outside the dhcp scope.

Create a configuration file on the device and assign the IP address on the device. How the configuration is created depends on the which service is used to connect to the network.

1 Like

The default hostname for your RPi is “raspberrypi” - so you can just use

ssh pi@raspberrypi.local

& never worry about IP again.

CORRECTION: manjaro-arm is the default hostname on Manjaro.
so it should be ssh username@manjaro-arm.local

raspberrypi.local will work for mac or linux, if you use windows I think just raspberrypi

Incorrect. It’s manjaro-arm until you set it to something else during setup.

oOps! Thanks, I just assumed it was raspberrypi os.

We assume the OS is Manjaro on the Manjaro forums. :wink:

1 Like