Raspberry Pi 4 sees but won't connect to wifi network

I am trynig to setup a raspberry pi 4 as an HTPC and I had it working except being able to watch streaming video services. I found Chromium-Docker for getting widevine support. Installed it and after that I could no longer connect to the wifi network.

The pi tries to connect but after a while I get a couple of popups, one says wifi deactivated, and the other says no secrets provided.

Delete ALL connections, re-setup?
(check /etc/NetworkManager/system-connections/ is empty)
OR, get better cables

A wifi dongle on longish (fat) cable is often useful

Thanks, I’ve tried recreating the connection, I’ve also created a second network on my access point neither helped. I tried a different HDMI cable it didn’t help, I am running at 1080p, which seems doesn’t cause interference…

I did upgrade to kernel 5.8 that didn’t change anything either, other than the system runs a bit faster.

OK, then maybe (systemctl) stop|disable NetworkManager,
plug in ethernet, get wicd or connman or setup wpa_supplicant
(last is installed already, a little bit painful to setup)

wicd appears to not be in the repo.

I was able to install and get connman going.

Looking to see what technologies are available it shows this:

  Name = WiFi
  Type = wifi
  Powered = False
  Connected = False
  Tethering = False

I then

connmanctl> enable wifi
Enabled wifi

I was then able to see my network:

connmanctl> services
*AO Wired                ethernet_0e0c36e493e6_cable
    More Pie             wifi_dca6324f2f3a_4d6f726520506965_managed_psk

But I seem to have hit then end of my ability to move forward I can’t seem to figure out the connect command

connmanctl> connect 'More Pie'
Error 'connect': Argument list too long

connmanctl> connect wifi_dca6324f2f3a_4d6f726520506965_managed_psk
Error /net/connman/service/wifi_dca6324f2f3a_4d6f726520506965_managed_psk: Method "Connect" with signature "" on interface "net.connman.Service" doesn't exist

I found an explination of the config file and now I’m getting:

connmanctl> connect wifi_dca6324f2f3a_4d6f726520506965_managed_psk
Error /net/connman/service/wifi_dca6324f2f3a_4d6f726520506965_managed_psk: Not registered

Learned about agent and:

connmanctl> agent on
Agent registered
connmanctl> connect wifi_dca6324f2f3a_4d6f726520506965_managed_psk
Agent RequestInput wifi_dca6324f2f3a_4d6f726520506965_managed_psk
  Passphrase = [ Type=psk, Requirement=mandatory ]
Agent ReportError wifi_dca6324f2f3a_4d6f726520506965_managed_psk
Error /net/connman/service/wifi_dca6324f2f3a_4d6f726520506965_managed_psk: Input/output error
Agent request cancelled by ConnMan

I tried with raspberry pi os and it was connecting to the wifi. So this seems to be a software issue.

Just checked the journal:

Oct 03 16:21:34 vidticus-miniman wpa_supplicant[435]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="More Pie>
Oct 03 16:21:34 vidticus-miniman wpa_supplicant[435]: wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 s>
Oct 03 16:21:31 vidticus-miniman wpa_supplicant[435]: wlan0: Trying to associate with SSID 'More Pie'
Oct 03 16:21:21 vidticus-miniman connmand[1260]: open error Not a directory for /var/lib/connman/wifi_dca6324f>

My wifi has always worked here. It seems it worked at one time for you which is strange. In the past some from other countries had to install and configure crda for their country. Other than that I am out of ideas other than your configs could be in a state of fruit salad with all of the stuff you have tried and configuring.


I did read some time back a person had to change his encryption method in the router.

I wonder if this should be done as root??
I don’t know if this will be helpful
You might see, ls -l /var/lib/connman
I mean, if it wants a directory, try giving it one
copy the filename to clipboard, delete file, mkdir paste name
If it doesn’t work, can always rmdir

Try searching for wicd- , it shows 6 items

1 Like

I got rid of the configs I made then followed the steps in the arch wiki, i started in interactive mode before, and was able to connect to the unsecured network I setup to test with. I then installed cmst and was able to connect to my secured network through that. I am going to reboot to see if it reconnects. :crossed_fingers:

It looks like wicd is in the AUR i haven’t enabled AUR in the GUI.

I rebooted a few times and I seem to have a reliable connection. No root required.

Was that an accurate error message?
ls -l /var/lib/connman
Great that it works, I’ve never really liked NM, powerful though it is

It was copied from the terminal. :man_shrugging:

There must have been something that didn’t happen when I first started connman, when I googled the error I found the making the config instructions I followed, which changed the error, but still wouldn’t connect. But when I deleted the config and used the gui it worked, and is still working.

I agree about NM, it’s great when it works, but when there are problems it gets in your way more often than not.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.