Random short touchpad freezes

I’ve managed to install and use the synaptics driver (xinput list-props "ELAN130...." shows the synaptics is in use), but I get freezes as well using it.

Can you install hid-tools and run sudo hid-recorder > hid_reports? If possible, also identify the lines when your touchpad freezes. Then upload hid_reports somewhere and share the link with me.

I can only do this Sunday afternoon. I will let you know when it is ready

Btw, after running hid-recorder, you can also run “sudo hid-replay hid_reports” to see if the problem can be reproduced.

I froze for several swipes.

When I replay the log file the cursor seems to make the same freeze, but it only moves on the upper edge of the screen; my touchpad movements were done in the middle part of the screen.

Here’s what I see on my screen,
(left to right)
(right to left)

I see three pauses at point a, b and c respective. All the movements are done in a non-stop, continuous way, right?

Can you try GitHub - coiby/standalone_i2c_hid at polling_regardless_of_gpio_pin_state and then paste the result of hid-recorder?

Hello @coiby

I still get freezes with the github code. DO you need some more traces?

Thank you for providing the feedback! It seems your touchpad hasn’t been set up properly by the driver. Is it possible for me to access your OS via Teamviewer to debug this issue?

Hello @coiby I’ve send you a private message

Thank you! Meanwhile can you do me a favor to show me the result of sudo cat /sys/kernel/debug/gpio|grep -A1 "pin16\s"?

$ sudo cat /sys/kernel/debug/gpio|grep -A1 "pin16\s"
pin16     interrupt is disabled| interrupt is masked| disable wakeup in S0i3 state| disable wakeup in S3 state|
 disable wakeup in S4/S5 state| input is low|   pull-up is disabled| pull-down is enabled|   output is disabled|   0x40000

I’m going to submit a patch soon to fix another touchpad (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1887190) and I need to make sure it won’t cause any regression.

On my laptop the output looks like this

pin16   Level trigger| Active low| interrupt is enabled| interrupt is unmasked| enable wakeup in S0i3 state| disable wakeup in S3 state|
 disable wakeup in S4/S5 state| input is high| 4k pull-up| pull-up is enabled| Pull-down is disabled|   output is disabled| 0x153b40

Hi guys, is there any progress on this? I’m using ASUS M513 and Ubuntu 20.04 and I can confirm the same touchpad mouse freezes that are random. The touchpad scroll works all the time as well. I noticed the same issues using GParted bootable iso. It works fine on Windows 10 so it can’t be a hardware issue. Also I tried both synaptics driver and libinput

@coiby do you have some new ideas about this problem? I could give you remote access again if you need it

Any news on this issue?

I recently got a Lenovo Thinkpad T490 and in the past week, started to experience this problem…when using the trackpoint or when using trackpad.

Very frustrating…

Hope there’s progress on this problem.



Hi @ArchiMark,

Could you share your laptop’s ACPI DST? https://bugzilla.kernel.org/show_bug.cgi?id=212379 provides a new clue to investigate the root cause of this bug.

You can use the following commands to get dsdt.dsl (you need to install acpica which provides iasl)

a) sudo acpidump > acpidata.out
b) acpixtract -sSSDT acpidata.out
c) acpixtract -sDSDT acpidata.out
d) iasl -da dsdt.dat ssdt*.dat

If the steps after a) fail, you can simply upload acpidata.out.

If you can understand the discussion in https://bugzilla.kernel.org/show_bug.cgi?id=212379, you can even check if the workaround in https://bugzilla.kernel.org/show_bug.cgi?id=212379#c31 works .

I had similar issue, here is my post with solution

1 Like

Hi @coiby
Sorry for the very very late reply…

I had another issue with laptop and Lenovo tech guy came and decided that trackpoint unit was problem. So, he replaced keyboard / trackpoint.

Thank you @Caraffa it seems that using the latest RT kernel is the solution for this problem.

I will get back if I get the error again.

I have been experiencing the same random short freeze of touchpad on my laptop as well. :frowning:

$ sudo inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=06d7363a-23c3-4c3d-97e3-3bc65484e084 ro quiet apparmor=1
    security=apparmor udev.log_priority=3
  Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X513IA_KM513IA
    v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X513IA v: 1.0 serial: <filter>
    UEFI: American Megatrends v: X513IA.300 date: 06/05/2020
  ID-1: BAT0 charge: 28.9 Wh (87.8%) condition: 32.9/42.1 Wh (78.1%)
    volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: Discharging cycles: 503
  RAM: total: 7.25 GiB used: 3.01 GiB (41.4%)
  Array-1: capacity: 32 GiB slots: 2 EC: None max-module-size: 16 GiB
    note: est.
  Device-1: DIMM 0 size: 4 GiB speed: 3200 MT/s type: DDR4
    detail: synchronous unbuffered (unregistered) bus-width: 64 bits
    total: 64 bits manufacturer: Hynix part-no: HMA851S6CJR6N-XN serial: N/A
  Device-2: DIMM 0 size: 4 GiB speed: 3200 MT/s type: DDR4
    detail: synchronous unbuffered (unregistered) bus-width: 64 bits
    total: 64 bits manufacturer: Samsung part-no: M471A5244CB0-CWE
    serial: <filter>
  Info: model: AMD Ryzen 7 4700U with Radeon Graphics socket: FP6 bits: 64
    type: MCP arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600103
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1475 high: 2000 min/max: 1400/2000 boost: enabled
    base/boost: 2000/4200 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1400 2: 1400 3: 1400 4: 1400
    5: 2000 6: 1400 7: 1400 8: 1400 bogomips: 31958
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel
    bus-ID: 03:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-3:3 chip-ID: 13d3:56a8 class-ID: 0e02 serial: <filter>
  Display: server: X.Org compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
    diag: 395mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 01:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlp1s0 state: down mac: <filter>
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
    bus-ID: 2-2:4 chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp3s0f3u2 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-2:2
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 4 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.14 TiB used: 79.67 GiB (6.8%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM256GDJTNG-8310A size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: 80001C00 temp: 35.9 C scheme: GPT
  SMART: yes health: PASSED on: 24d 20h cycles: 5,266
    read-units: 52,307,627 [26.7 TB] written-units: 9,075,129 [4.64 TB]
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10SPZX-80Z10T2 family: Blue Mobile (SMR) size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A04 temp: 31 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 162d 2h cycles: 5264 Old-Age:
    g-sense error rate: 413
  Message: No optical or floppy data found.
  ID-1: / raw-size: 52.2 GiB size: 51.13 GiB (97.95%) used: 24.09 GiB (47.1%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A
    uuid: 06d7363a-23c3-4c3d-97e3-3bc65484e084
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 66.8 MiB (26.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1 label: SYSTEM uuid: DA44-C033
  ID-3: /home raw-size: 34.8 GiB size: 34 GiB (97.71%)
    used: 30.41 GiB (89.4%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6 label: N/A uuid: 941c21f5-3c1e-45ab-8989-ce9c68b0c218
  ID-4: /run/timeshift/backup raw-size: 30 GiB size: 29.36 GiB (97.86%)
    used: 24.37 GiB (83.0%) fs: ext4 block-size: 4096 B dev: /dev/sda2
    maj-min: 8:2 label: Manjaro-recovery
    uuid: ab4be4b9-eb3d-43ea-a32c-8763e70be217
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 11 GiB used: 755.2 MiB (6.7%)
    priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4 label: N/A
    uuid: feb7c417-87a9-413c-ae17-fb925a517a01
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: N/A label: N/A
    uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 139.18 GiB fs: ntfs label: OS
    uuid: DC20475720473832
  ID-3: /dev/nvme0n1p7 maj-min: 259:7 size: 1.03 GiB fs: ntfs
    label: RECOVERY uuid: E6BAAD46BAAD13D9
  ID-4: /dev/sda1 maj-min: 8:1 size: 901.51 GiB fs: ntfs label: New Volume
    uuid: 800C3F790C3F6974
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:8 info: No brand USB OPTICAL MOUSE type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 2188:0ae1 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-2:4 info: ASIX AX88179 Gigabit Ethernet type: Network
    driver: ax88179_178a interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 496mA
    chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
    class-ID: e001
  Device-2: 3-3:3 info: IMC Networks USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:56a8 class-ID: 0e02 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: amdgpu temp: 37.0 C
  Fan Speeds (RPM): cpu: 2300
  Processes: 280 Uptime: 2d 1h 48m wakeups: 47 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1418
  pacman: 1415 lib: 387 flatpak: 3 Shell: Zsh (sudo) v: 5.8
  running-in: konsole inxi: 3.3.12