Random logout from X session

Hi, I have been using Manjaro as my daily driver for over a year now, and I have been experiencing a recurrent issue whenever I use the Discord’s voice channels either by an installed package or a Chromium based browser. The issue is that I can have the system running all day with Discord open or the page loaded in Vivaldi and this does not happen. But once I join a voice channel it kicks me out of my X session and I have to log in again.

It seems that it may be something related to Chromium as this does not happen with Firefox (I can be logged in all day and it never happened in that specific browser) and this happens in both my laptop and desktop . I have tried reinstalling the package, removing Vivaldi but nothing seems to resolve it and it also happens to a friend. This has happend in Enlightenment on my laptop and Xfce in my desktop.

I started having this issue about six months ago, and I was getting used to keep opening Discord in Firefox but now I am having an USB headset issue with this specific browser and I wanted to use any Discord package (AUR, Flatpak and Sanp) or fork that may solve the issue for me.

My Laptop setup is

Please let me know any information you may need from my end.

Thank you!

did you try brave??
and it has nothing to do with you laptop specifications

I have tried Brave in the past for a week or two, and I installed it now. It seems that is also affecting Brave which a fresh installed package without any add-ons or something else. Perhaps, it is something related to Chromium based packages, but I don’t know how to check if that is the root cause of the issue.

did you try opera
it does not give any type of problems

To be honest I have no tried in Opera, but it seems that I cannot have the discord package installed by any means when I have a chromium based browser installed at the same time. Will try Opera tomorrow and see what results it drops me.

I have tried Opera for over four days and it seems to be happening kind of similar how it was with Vivaldi. I have to add that I also joined a Google Meet room last evening and I was logged out sent back to LightDM screen. In my desktop pc has not happened yet because I reinstalled Manjaro and I am using Firefox with the Lightcord package from the AUR Discord and no chromium based browser but I have not used the Discord package very much yet.