Random, hard freeze. Can't diagnose it and REISUB doesn't help

Hi guys, I’m new here. I have KDE Manjaro installation. It freezes randomly, I can’t detect any possible trigger. My computer doesn’t freeze while using Windows 7.

The most frustrating thing is that I can’t REISUB it and nothing I tried helps. REISUB does work while the computer is in normal condition so it’s not disabled or anything like that.

What frustrates me most is that I don’t know how to diagnose this issue. Why would the OS freeze so hard that I can’t even return to the terminal? Why wouldn’t it at least “BSOD” (I know it’s not a Linux thing) or something like that instead of getting completely paralyzed?

So my question is, how can I troubleshoot this? Is there a way to debug it? Any ideas? Logs? It happens every day.

Ryzen 7 1700X
MSI X370 Gaming Pro Carbon
Radeon RX 580 8GB
NVMe drive (Dual booting with Win7)

See if this might be applicable:

Have you added numerous widgets or themes? Try switching everything back to Breeze or Breath and disabling widgets. See if the problem persists. If good, you can start back with adding things you like one at a time.

Also please read:

My first suggestions is always: have your run memtest? Hardware often seems to be the root cause of my freezes.

I have a very similar build to yours and had a lot of freezes to begin with. Mostly down to me running the memory too fast - my Ryzen 7 1700 can’t handle more than 2400hz (even tho memory is rated to 3000). Dropped speed to 2400 in bios and things were much better.

Had a bit of an issue with my NVMe drive too, using a particular kernel option to get around that IIRC.

I haven’t added any widgets or themes. It’s very plain in that regard.

Done memtest, nothing came up. I also set my RAM to 2400 in case that might be the problem but nothing.

The NVMe kernel option sounds like a possibility. Can you remember what it is? Or can you at least point me in the direction I should take to get it?

Just as a reminder, the computer works fine in Win7 so I don’t think it’s related to RAM.

Might be a kernel issue. Try updating the kernel. Have a look here.

Worked for me & others.

Here are my notes regarding my nvme drive, was very specific to the brand/model.

# Seem to be many people having issues with this drive
Kingston SA2000M8250G (S5Z42105)
# number in brackets is bios version - which is latest
# possible fix for grub cmdline
nvme_core.default_ps_max_latency_us=5500 pcie_aspm=off
# or
nvme_core.default_ps_max_latency_us=0 pci_aspm=performance
# or possibly just

sudo -s
nvim /etc/default/grub
# default line changed to
GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor udev.log_priority=3 nvme_core.default_ps_max_latency_us=5500"
# and removed existing pci_aspm=off, will see how this goes
# update grub
sudo update-grub
# need to reboot...

# check after reboot
cat /sys/module/nvme_core/parameters/default_ps_max_latency_us
# reports

Hope that helps.

1 Like