Random freezing during gaming

I installed Manjaro (KDE Plasma) yesterday and it’s been working great for the most part. Proton games on steam work fine, until they don’t. Sometimes with a game open my whole computer will lock up. I mean completely, the only thing moving on screen is my mouse pointer, and nothing else. Most of the time I can hear audio still, and can hear stuff like opening/closing menus in game, so the game is still running, and I can interact with it. The only way to get the system back is to force shut down by holding the power button or shutting it down through KDE Connect on my phone. At first the freezes seemed to happen when I closed the game or alt-tabbed from the game, but now its happened at least once during just normal gameplay, no alt-tabbing or closing windows.

It might be worth noting that the games I’ve played so far since install have been mostly proton games, mainly Satisfactory, but the freeze has happened in Counter Strike 2, which is Linux native (I think?).

I’m on a laptop with a GTX 1660 Ti. The graphics drivers are installed, the performance in games is good and the NVIDIA X Server Settings app exists. I’ve done a fair bit of googling and have come up with no solution so far. Any help would be greatly appreciated!

1 Like

inxi -Fazy

is a good start.

Here the output of inxi -Fazy:

  Kernel: 6.5.11-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=d8a1f517-ec7f-4e03-97c5-f7ca498dca93 rw quiet splash
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-dk0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 85FB v: 42.47 serial: <superuser required> UEFI: Insyde
    v: F.50 date: 08/18/2021
  ID-1: BAT1 charge: 40.3 Wh (100.0%) condition: 40.3/52.5 Wh (76.8%)
    volts: 12.8 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
    serial: <filter> status: full
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xFA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 806 high: 847 min/max: 800/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 807
    5: 800 6: 847 7: 800 8: 800 bogomips: 38408
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: none off: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]
    vendor: Hewlett-Packard driver: nvidia v: 535.129.03
    alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
    2023-11; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
    built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:2191 class-ID: 0300
  Device-3: Quanta HP Wide Vision HD Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0408:5300
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa dri: iris
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 950x285mm (37.40x11.22")
    s-diag: 992mm (39.05")
  Monitor-1: DP-1-0 pos: bottom-l res: 1680x1050 hz: 60 dpi: 90
    size: 474x296mm (18.66x11.65") diag: 559mm (22") modes: N/A
  Monitor-2: HDMI-1-0 pos: primary,top-right res: 1920x1080 dpi: 92
    size: 532x304mm (20.94x11.97") diag: 613mm (24.12") modes: N/A
  Monitor-3: eDP-1 size-res: N/A modes: N/A
  API: EGL Message: No EGL data available.
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.1.9-manjaro1.1 glx-v: 1.4
    es-v: 3.2 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    device-ID: 8086:3e9b memory: 15.1 GiB unified: yes
  API: Vulkan v: 1.3.269 layers: 5 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 1660 Ti with Max-Q Design driver: nvidia v: 535.129.03
    device-ID: 10de:2191 surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU116 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
  API: ALSA v: k6.5.11-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.85 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-4.4:3
    chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp0s20f0u4u4 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:4
    chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 969.95 GiB used: 147.67 GiB (15.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: HBRPEKNX0202AH
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 tech: SSD serial: <filter> fw-rev: HPS1 temp: 44.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Intel model: HBRPEKNX0202AHO
    size: 27.25 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 tech: SSD serial: <filter> fw-rev: HPS2 temp: 55.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS545050A7E680
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: AF10 scheme: GPT
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 147.67 GiB (31.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 27.25 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme1n1p1 maj-min: 259:4
  System Temperatures: cpu: 59.0 C pch: 60.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 267 Uptime: 23m wakeups: 0 Memory: total: 16 GiB
  available: 15.47 GiB used: 5.38 GiB (34.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1162 libs: 346 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31

And please

mhwd -li -l

Here’s mhwd -li -l:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!
> 0000:01:00.0 (0300:10de:2191) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

> 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Provide output for

glxinfo | grep "OpenGL renderer"
prime-run glxinfo | grep "OpenGL renderer"

Here you go:
(Sent as an image because I don’t know if that empty line signifies anything)

Also tried upgrading the kernel from 6.5.11-1 to 6.6.1-1 in hopes that it might fix it, read somewhere that it might. Unfortunately it didn’t fix it.

Your games are run on Intel integrated graphics instead of NVIDIA GPU. As a result your CPU overheats and freezes start to appear.

Add prime-run to .desktop files you use to launch your games from

I’m pretty sure it’s running on the NVIDIA GPU based on the framerates I’m getting, there’s no way the games would run this well on the integrated graphics. I’ll try though just to make sure. I don’t use .desktop files though, I launch the game directly through steam, so I’m guessing I need to add it in some place in steam.

Yeah I can’t seem to figure out any way to add prime-run to steam games manually, but I’m 99,99% sure that it is running on the NVIDIA GPU. I’m getting a good framerate very similar to what I got on windows, and on windows it was definitely using the NVIDIA GPU. There is just no way the integrated GPU could run the game this well. I’d guess that steam automatically forces use of the NVIDIA GPU.

Do not look at framerate, look at the CPU temperature

I’m pretty certain that it’s physically impossible for it to be the iGPU rendering the frames, since it just cannot do it that fast. But I’ll have the CPU temp on my second monitor next time I play and I’ll see if it overheats.

Alright reporting back with new results. CPU temp sat around 90C for a long time before the freeze. I’ve observed this same behaviour on Windows too, nothing out of the ordinary for it to be at 90C (because laptop cooling sucks). It didn’t suddenly spike before freezing or anything like that. This time it was in a game of Counter Strike 2, in which I got framerates of up to 100, CS2 would not run at 100fps on an iGPU. So it’s 100% certain that it is running on the NVIDIA GPU.

I believe that the fact that I can still interact with the software and that its obviously still running points to some graphics issue. The game is still clearly open, despite the screen being frozen, I can hear the buttons being pressed, etc. This time I was also in a Discord call, and I could still hear the other person and they could hear me after the freeze, so the system is still running. It’s only the display output that abruptly freezes.

You can copy empty lines too. :smiley:

$ echo -e "\nthis was copied from a terminal"

this was copied from a terminal

Yeah, I just thought it’d be better in image form so that the empty line wouldn’t be mistaken for a typo.

Some more info:
I went into the NVIDIA X Server Settings > PowerMizer and set “Preferred Mode” to “Prefer Maximum Performance”, in hopes that it might make a difference.

While playing Counter Strike 2 just now after the change, I encountered a similar issue to the freezing. Instead of what it’s been doing till now. Only my other monitor and taskbar (I think KDE calls it the task manager?) froze and became unresponsive. I could still alt+tab on my main monitor, and get into the game (albeit with a task bar popup on screen). Still had to reboot to fix it though. Although this time I was able to reboot by opening a terminal with Ctrl+Alt+T and reboot from there instead of using KDE Connect on my phone.

Alright, I believe that I’ve fixed it. I managed to play Satisfactory for a bit over two hours without any freezing. I installed envycontrol and ran sudo envycontrol -s nvidia --force-comp, and rebooted. Since then I’ve had the envycontrol icon on my task bar/task manager and haven’t had any freezing (so far). Before I set it to nvidia it was on hybrid mode, so I’m guessing the issue stemmed from both the iGPU and GPU being used at the same time, or switching from one to the other. I don’t know if this was the only thing needed to fix the issue, or if it’s fixed now thanks to the combination of envycontrol and everything else I did earlier. Will mark this as a solution if the freezing doesn’t happen after a while.

If you were somehow using the nvidia … then the change here is probably due to the ‘force full composition pipeline’ that I assume that final envycontrol flag equates to.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.