Random Freezes (Screen Hangs) with new Install

I installed latest version of Manjaro KDE (Mikah 20.1.1). I have a lenovo legion y540 laptop. I used non- free drivers for the installation, which resulted in video-nvidia-450xx being installed as the graphic card driver. Due to very random and frequent freezes I tried a re-install with free drivers and it installed video-linux as the driver for graphic card and now it works smoothly and hasn’t freezed ever since that.

But I cannot use the graphic card for my work anymore nvidia-smi shows command not found but it worked when the drivers were nvidia-video-450xx. Here’s the output of inxi -Fza , is there a way to use nvidia GPU with this driver or is it possible I revert back to the nvidia-video-450xx without any freezing issue? TIA

System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=34350ef1-de2e-48f5-beec-b1ce4559426c rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81SY v: Lenovo Legion Y540-15IRH-PG0 serial: <filter> Chassis: type: 10 
           v: Lenovo Legion Y540-15IRH-PG0 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> UEFI: LENOVO v: BHCN31WW date: 08/20/2019 
Battery:   ID-1: BAT0 charge: 47.2 Wh condition: 47.2/52.5 Wh (90%) volts: 12.8/11.2 model: SMP L17M3PG1 type: Li-poly 
           serial: <filter> status: Full cycles: 485 
CPU:       Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: D6 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38408 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Lenovo driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:1f91 
           Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo bus ID: 1-6:3 chip ID: 04ca:7070 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: modesetting,nouveau alternate: fbdev,nv,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: llvmpipe (LLVM 10.0.1 256 bits) v: 3.3 Mesa 20.1.8 compat-v: 3.1 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10fa 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 07:00.0 chip ID: 10ec:8168 
           IF: enp7s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1011.15 GiB used: 119.87 GiB (11.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW010T8L size: 953.87 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: L12C scheme: GPT 
           ID-2: /dev/sda type: USB vendor: SanDisk model: Ultra size: 57.28 GiB block size: physical: 512 B logical: 512 B 
           serial: <filter> rev: 1.00 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: 60.00 GiB size: 58.81 GiB (98.01%) used: 8.17 GiB (13.9%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-2: /home raw size: 133.95 GiB size: 130.84 GiB (97.68%) used: 111.01 GiB (84.8%) fs: ext3 dev: /dev/nvme0n1p8 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 5.86 GiB used: 675.3 MiB (11.3%) priority: -2 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 65.0 C mobo: N/A gpu: nouveau temp: 37 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 268 Uptime: 2d 10h 46m Memory: 7.70 GiB used: 5.40 GiB (70.2%) Init: systemd v: 246 Compilers: 
           gcc: 10.2.0 Packages: pacman: 1182 lib: 319 flatpak: 0 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.05 

Try older driver like the 440 if you want. It is more stable then the latest and greatest. I just recently started to have random black screen with 455 and 450 drivers, no issue with 440, so for now I stick with 440 as I’m not finding the issue beside driver version.

System Settings -> Hardware Configuration -> (uninstall current driver if nvidia) -> Install desired driver

Thanks, will try that.

Yes, downgrading to 440xx solved it. Thanks.

Nice. You may want to try again the latest drivers after the next update to a greater version than the current one. Some bug may have been squashed next time and help your issue. Same procedure then
System Settings -> Hardware Configuration -> (uninstall current driver if nvidia) -> Install desired driver

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.