Random freezes on Manjaro

I’ve been using Manjaro on a Xenon desktop for 2/3 months now. I have experience random freezes for some time - perhaps a week or two. Nothing majors has changed that I can think of. I’ve found a few other topics on similar-ish issues. It used to be a dual boot Mint/Manjaro but I now I only have Manjaro. This may be the only major change I can think of.

I noticed I have been running on kernel 5.9, I downgraded to 5.4 at this seems to have fixed other’s issues. Some mentioned perhaps graphic cards drivers may be the issue, so I have changed from the nouveau to the non-free drivers. As this is a random issue, hard to tell if it worked - will be watching for a few days & get back on updates as to wether or not it has worked.

Any thoughts on other things I could check? journalctl logs but I couldn’t find obvious reasons for the reasons (though I’m not super experienced in navigating those logs to be honest).

EDITS based on comments:

  • Freeze is immediate during light task/nothing special happening. Could be browsing, could be writing something on a textpad, etc. Haven’t noticed any specific action/action type that triggers it. Doesn’t seem related to heavy usage
  • Not linked to memory usage/ram maxed out etc (few things actually running). Could be after restart or if I haven’t restarted in a while.
  • I have 32 go of ram at any rate, and rarely do anything that really pushes me close to that limit.
  • I can’t do anything once it freezes. Has to force a hard reboot. Absolutely nothing seems to have any sort of impact.


[fv@fv-hpz420workstation ~]$ uname -rv
5.4.67-1-MANJARO #1 SMP PREEMPT Wed Sep 23 14:20:18 UTC 2020

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 46 bits physical, 48 bits virtual
CPU(s): 12
On-line CPU(s) list: 0-11
Thread(s) per core: 2
Core(s) per socket: 6
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 45
Model name: Intel(R) Xeon(R) CPU E5-1650 0 @ 3.20GHz
[fv@fv-hpz420workstation ~]$ inxi -Fxz
Kernel: 5.4.67-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
Desktop: Xfce 4.14.2 Distro: Manjaro Linux
Type: Desktop System: Hewlett-Packard product: HP Z420 Workstation v: N/A
Mobo: Hewlett-Packard model: 1589 v: 0.00 serial:
UEFI: Hewlett-Packard v: J61 v03.92 date: 02/09/2018
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360
charge: 100% (should be ignored) status: Discharging
Device-2: hidpp_battery_1
model: Logitech M720 Triathlon Multi-Device Mouse
charge: 100% (should be ignored) status: Discharging
Topology: 6-Core model: Intel Xeon E5-1650 0 bits: 64 type: MT MCP
arch: Sandy Bridge rev: 7 L2 cache: 12.0 MiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76654
Speed: 1197 MHz min/max: 1200/3800 MHz Core speeds (MHz): 1: 1197 2: 1197
3: 1197 4: 1197 5: 1197 6: 1197 7: 1197 8: 1197 9: 1197 10: 1197 11: 1197
12: 1197
Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI
driver: nvidia v: 450.66 bus ID: 05:00.0
Display: x11 server: X.Org 1.20.9 driver: nvidia resolution:
1: 1920x1080~60Hz 2: 1920x1080~60Hz
OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66
direct render: Yes
Device-1: Intel C600/X79 series High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus ID: 05:00.1
Sound Server: ALSA v: k5.4.67-1-MANJARO
Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: 3.2.6-k port: e040 bus ID: 00:19.0
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 1.03 TiB used: 19.69 GiB (1.9%)
ID-1: /dev/sda vendor: Western Digital model: WD1002FAEX-00Y9A0
size: 931.51 GiB
ID-2: /dev/sdb vendor: Kingston model: SA400S37120G size: 111.79 GiB
ID-3: /dev/sdc type: USB vendor: Philips model: USB Flash Drive
size: 14.77 GiB
ID-1: / size: 49.24 GiB used: 8.58 GiB (17.4%) fs: ext4 dev: /dev/sdb2
ID-2: /home size: 59.80 GiB used: 1.03 GiB (1.7%) fs: ext4 dev: /dev/sdb3
Alert: No Swap data was found.
System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 47 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 50%
Processes: 276 Uptime: 3h 12m Memory: 31.30 GiB used: 3.46 GiB (11.1%)
Init: systemd Compilers: gcc: N/A Packages: 1063 Shell: Bash v: 5.0.18
inxi: 3.1.05

Welcome at the forum, @franckyvee

a good starting point could be to provide some info of your system:

Also tell us how long the freezes usually take and when they appear in case you see a pattern. What about CPU and memory usage when it appears and so on.

Added details in the OP for easier references.

So far downgrading to 5.4 seems to have work. No freeze for a full day. Perhaps there is something in 5.9 that’s causing the issue, or something with 5.9 & my system. Other option would be the Nvidia drivers. If the fix holds, I might try rebooting on 5.9 once in a while to see if it freezes up again. If it doesn’t, I guess it would be the Nvidia drivers have fixed the issue (and thus the nouveau graphic drivers would be faulty).

Changing the kernel is always a good idea if freezes occur, especially if you tried the newest kernel (5.9). Keep your system updated and I also would recommend to think about installing timeshift to backup your system on an external device. :innocent:

Hey Wollie,

Yup timeshift is a good idea.

Really seems like either the downgrade or the drivers did the trick. Still no freezes.

This means there’s an issue with either 5.9 or the open nvidia drivers. Working a fair bit theses days so not really into testing out which one it was, but eventually will get around & post here if anything.

So 1 proposed solution, one of which has worked:

  • Downgrade to 5.4 kernel
  • install the nonfree nvidia drivers
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.