Random freezes occur to be fixed only by hard reset

Random freezes occur in my Laptop during light tasks such as using Firefox or just hovering over the icons. The cursor gets stuck and the keyboard becomes unresponsive. The only fix I found is to hard reset it by pressing and holding Power button for a couple of seconds.
this happens in every kernel I have tried. Although it does not occur frequently but then too it frustrates me a lot. Yesterday I was just turning off the wifi and the cursor freezed leaving the laptop unusable.
inxi -Fxz

System:    Host: nikhil-hpnotebook Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.19.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: <filter> 
           Mobo: HP model: 81F6 v: 66.26 serial: <filter> UEFI [Legacy]: Insyde v: F.35 date: 05/27/2019 
Battery:   ID-1: BAT1 charge: 17.3 Wh condition: 35.4/35.4 Wh (100%) model: 131-42-6E HS04041 
           status: Charging 
CPU:       Topology: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics bits: 64 type: MCP 
           arch: Puma rev: 1 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 17573 
           Speed: 998 MHz min/max: 1000/2200 MHz Core speeds (MHz): 1: 998 2: 998 3: 998 4: 998 
Graphics:  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard driver: amdgpu v: kernel 
           bus ID: 00:01.0 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] 
           vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD KABINI (DRM 3.37.0 5.7.9-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.1.3 
           direct render: Yes 
Audio:     Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 
           Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Sound Server: ALSA v: k5.7.9-1-MANJARO 
Network:   Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard 
           driver: rtl8723be v: kernel port: 3000 bus ID: 02:00.0 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 
           v: kernel port: 2000 bus ID: 03:00.0 
           IF: enp3s0 state: down mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
           IF-ID-2: virbr0-nic state: down mac: <filter> 
           IF-ID-3: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-4: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 76.13 GiB (8.2%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-60JC3T0 size: 931.51 GiB 
Partition: ID-1: / size: 392.72 GiB used: 76.13 GiB (19.4%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 49.1 C mobo: 20.0 C 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 41 C device: amdgpu temp: 48 C 
Info:      Processes: 204 Uptime: 24m Memory: 3.32 GiB used: 1.44 GiB (43.5%) Init: systemd Compilers: 
           gcc: 10.1.0 Shell: bash v: 5.0.18 inxi: 3.0.37

I’ve had the same issues with Plasma last night, but in a different distro.

Might be an issue with Plasma itself?

All I was doing was tinkering with a desktop widget and it hard locked on me, and even after a reboot it stayed the same. Might need to reset the DE…

1 Like

After reboot the problem was fixed for me. I happened maybe thrice in 2 weeks. But now it’s almost normal but dunno if the issue strikes me again.

I had these too. Fixed it by downgrading kernel to 5.6.

version 5.6 is EndOfLife ( EOL )
so you should goback to
version 5.4 LTS or 4.19 LTS or 4.14 LTS

UEFI [Legacy]

some options is not good in your Bios

have you checked

sudo journalctl -b0 -p4 

But kernel 5.6 is reaching end of life hence I want to live with kernel 5.7 or later only. Kernel 5.4 and 5.6 cause my system to bake out a temperatures above 70 degree C. Kernel 5.7 handles thermals better and also is good toward battery life. My laptop’s CPU was launched in 2015 but dont don’t know why the newer kernels help.

I see only 4GB ram and no swap, which might not be enough for your (firefox?) usage. Enable some swap.

1 Like

This has been an ongoing problem for me ever since the release of AMD’s 5700XT GPU and the updated amdgpu kernel module to go with it. The symptoms are exactly the same, random freezes especially after waking from sleep.

Knocking wood, it hasn’t happened for a few months now. I updated to the 5.7 kernel (recently upped again to 5.8) and also configured to disabled all USB before system sleep. I think the latter is what really fixed the problem.

I had swap file initially but the apps switch to swap quite frequently that causes lag on my system. I have a HDD, and we know how slow is HDD.
Is there any way so that system not switches to swap quite frequently, and how much swap do I actually require if my usage is quite light with some Firefox tabs open and maybe some documents on Okular? Is 2GB enough?

Please don’t do that! :sob:

Use this instead:

1 Like

Agreed 100% if this works. Forced power-offs regularly result in filesystem corruption.

I’d suggest having a swap partition of about 1.5x your RAM with 4GB … and I’d also suggest increasing the physical RAM if you can.

(Typo corrected.)

1 Like