Random artifacting on 7700XT

I just bought a new 7700xt from XFX and have been trying to trace down an artifacting problem. It used to be occurring all the time when I was just watching YouTube or browsing Steam (see video). I thought it might be a bad cable so I swapped my two monitor cables and it seemed to fix it but now I am noticing it after a couple hours of playing games. Lately, I have noticed it in Minecraft which is probably the least intensive game I play on this card. I tried to capture it on video but it is too sporadic. It looks the same except maybe more green if that makes any difference

image removed

Please do not use screenshots.

Do not post images or screenshots as part of your topic. The forum is a technical forum not an image gallery.
Forum Rules - Manjaro

I am using Plasma on Wayland with AMD and 7900XTX - admittingly I am not a hardcore gamer - but I do watch a lot of video.

I also play House of DaVinci fullscreen on a Samsung Odessy G9 - no issues.

I suppose I will provide an update since this did not gain much traction. I think I have

finally figured out that this is related to when I have my second monitor plugged in

even though it only occurs on my main monitor. I have an Asus 1440p 144hz as my main monitor (I did try limiting it to 60hz to no avail) and an Asus 4k 60hz as my secondary both connect with a DP cable although I did try switching to HDMI

Just a thought … until recently - in fact when I first commented on this - my desktop was in the upright position. I decided to see if I could reproduce what you describe - so I put my workstaion to a horizontal position and placed a second monitor on top of the desktop.

When a 7900XTX GPU is seated - in terms of weight, it is a heavy card - so it is of great importance you are using the support stands supplied with the card.

When you get artifacts it may be caused by the card slightly ‘hanging’ perhaps in a slightly ‘push up’ position, causing strain on the PCIe connector on the board - perhaps injecting occasional bad connection on one of the pins.

I was using the support stand but I had occasional flicker in the left 25% of my 5K monitor - it was espcially visible during boot - and it could appear during normal use as well.

Now that I revisit this topic it occurred to me - I have not seen the mentioned flicker since the change of position.

The change of position means that while my GPU was horizontal before it is now standing vertical on top of the system board.

Thus the question

  • is your GPU ‘hanging’ horizontally from the PCIe connector ?
  • or is it ‘standing’ vertically on the PCIe connector ?

In fact, there has been - a while ago - issues with AMD GPUs where the horizontal position would cause the cooling to fail due to a construction flaw - if I recall correct the cooliing fluid would stop circulating causing the board to overheat and die.

in fact, the first charge on market had issues because they weren’t filled with enough cooling liquid but these cards shouldn’t be on market anymore.

1 Like

Did i get this right, that you finally fixed the issue with video rendering but the artifacts showing up only in games now?

I should have clarified the issue did return to normal nongaming usage after a little bit.

I will turn my PC on its side and report back on the results

The most 7700XT Models are much lighter than a 7900XTX, the beasts that are this heavy + leghts should have a Graphics Card Supporter like this card.

PULSE AMD Radeon RX 7900 XTX 24G GDDR6

I would just remove the GPU and blew inside the PCIe Slot or better use a vacuum clearner (non metal) and carefully remove the dust, if there are some dusts between the both connector’s while you inserted the GPU the last time, maybe that lead to the problems. :man_shrugging:

So I can say now that this was not the solution. My PC has been on its side for a while now and the problem still exists.

I did try this as well but still no good. As a last-ditch effort I tried swapping my GPU PCI slots (I have a Nvidia card for anything that I need to run in Windows). This made my X server very mad but I will fix this later.
Is there any way this could be a kernel or a driver issue? If this last test does not work I may not have another choice but to RMA my card and hope it was a factory defect.

I have no clue why a forum admin removed your screenshot, because it would possible show if its a hardware issue or not… post your screenshot again.

download the latest live-iso, download another live-iso from another distro like linux-mint. run both live-iso’s and check if there is artifacting on the live-iso’s.
report afterwards

I tried but I just get an error when I try to embed a screenshot or even just add a link in my reply if you really want to see it you can check imgur at 7700xt-artifact-NVDGesI

Can’t find anything… just post a link from imgur then.


So I thought I found a solid test for this issue. I found if I have Steam open on my second monitor with the summer sale banner animating (if it stops looping this doesn’t work) and then take a YouTube video on my main screen in and out of fullscreen it will artifact on the Steam screen. So I simulated this test on two different live images, ubuntu 22.4 and the latest manjaro with 6.9 which mirrors my install and neither could replicate it. Ok so good this confirms it is a driver issue right? Nope after booting back into my main install I could no longer replicate it. This issue is so frustrating to troubleshoot because it is so sporadic.

TL;DR Might be drivers but still not sure

First this looks like a minor problem to me, when its so sporadic and rare.

When its a driver problem, I would switching to different Kernels or evade using more than one Monitor to see if this is a dual monitor problem or not.

Playing around with compositor settings probably could help too.

Is there another kernel to try? 6.6 had other issues with the 7000 series cards and 6.7/6.8 are both EOL

I have already confirmed this

How would I go about this? I thought in previous versions of Manjaro they were in the settings app but they seem to have removed them

I’m not even sure which desktop you are using, is your profile up to date?
You still using KDE?

inxi --admin --verbosity=5 --filter --no-host --width

Now i see… its a Multi Monitor issue… you could mark this imported info’s with dark black and also update your Title:

Random artifacting on 7700XT when plugging in a second Monitor

6.10 Experimental or maybe 6.1 LTS but i have no idea if this kernel are working because your GPU is still newer than 6.1 Kernel release.

Apologies I have edited my last reply to have that info stand out. I would update the title but I seem to have lost edit ability on the main post? Anyways I will try the 6.10 kernel and see what that does. In the meantime here is the output of that command and yes I am using kde plasma

insxi output
  Kernel: 6.9.3-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9-x86_64
    root=UUID=05499c66-4c3b-4e75-9bf0-3477a74a1cdd rw processor.max_cstate=5
    quiet splash udev.log_priority=3 amd_iommu=on iommu=pt kvm_amd.npt=1
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
    wm: kwin_wayland vt: 3 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 4005 date: 07/13/2021
  System RAM: total: 32 GiB available: 31.26 GiB used: 19.02 GiB (60.9%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 128 GiB slots: 4 modules: 2 EC: None
    max-module-size: 32 GiB note: est.
  Device-1: DIMM_A1 type: no module installed
  Device-2: DIMM_A2 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 16 GiB speed: 3600 MT/s volts: note: check curr: 1 min: 1 max: 1
    width (bits): data: 64 total: 64 manufacturer: Corsair
    part-no: CMH32GX4M2D3600C18 serial: N/A
  Device-3: DIMM_B1 type: no module installed
  Device-4: DIMM_B2 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 16 GiB speed: 3600 MT/s volts: note: check curr: 1 min: 1 max: 1
    width (bits): data: 64 total: 64 manufacturer: Corsair
    part-no: CMH32GX4M2D3600C18 serial: N/A
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 1x32 MiB
  Speed (MHz): avg: 3901 high: 4650 min/max: 2200/4650 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 4647 2: 3716
    3: 4649 4: 3718 5: 3719 6: 3709 7: 4650 8: 2200 9: 4650 10: 3717 11: 3717
    12: 3720 bogomips: 88840
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; IBRS_FW;
    STIBP: always-on; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate] vendor: ASUSTeK
    driver: vfio-pci v: N/A alternate: nouveau non-free: 550.xx+ status: current
    (as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 4 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.0
    chip-ID: 10de:2489 class-ID: 0300
  Device-2: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] vendor: XFX
    driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
    built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-2,DP-3
    empty: DP-1,HDMI-A-1,Writeback-1 bus-ID: 0d:00.0 chip-ID: 1002:747e
    class-ID: 0300
  Display: wayland server: Xorg v: with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: vfio-pci,amdgpu d-rect: 4754x2674 display-ID: 0
  Monitor-1: DP-2 pos: primary,top-left res: 2560x1440 size: N/A modes: N/A
  Monitor-2: DP-3 pos: bottom-r res: 2194x1234 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7700 XT (radeonsi
    navi32 LLVM 17.0.6 DRM 3.57 6.9.3-3-MANJARO) device-ID: 1002:747e
    memory: 11.72 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 4 device: 0 type: discrete-gpu name: AMD
    Radeon RX 7700 XT (RADV NAVI32) driver: mesa radv v: 24.0.9-manjaro1.1
    device-ID: 1002:747e surfaces: xcb,xlib,wayland
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK driver: vfio-pci
    alternate: snd_hda_intel pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.1 chip-ID: 10de:228b
    class-ID: 0403
  Device-2: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-3: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-4: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-4:4
    chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
  API: ALSA v: k6.9.3-3-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 5 Wireless-AC 9x6x [Thunder Peak] driver: iwlwifi
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 06:00.0
    chip-ID: 8086:2526 class-ID: 0280
  IF: wlp6s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
  IF-ID-2: vnet0 state: unknown speed: 10000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-5:2
    chip-ID: 8087:0025 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 4.77 TiB used: 2.86 TiB (60.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P1SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P3CR010 temp: 45.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-08WN4A0
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: 1A01 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 QVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1B6Q scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC25 scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: Intel model: SSDSC2BP240G4
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 0420 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
    used: 547.78 GiB (59.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 05499c66-4c3b-4e75-9bf0-3477a74a1cdd
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 8AAC-8E13
  Alert: No swap data was found.
  System Temperatures: cpu: 76.5 C mobo: N/A gpu: amdgpu temp: 58.0 C
    mem: 71.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
  Processes: 294 Power: uptime: 8m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.47 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 1617 pm: pacman pkgs: 1612 libs: 493 tools: pamac,yay pm: flatpak
    pkgs: 5 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: yakuake inxi: 3.3.35

Edit: kernel 6.10 did not help

Taskbar>Settings>System Settings>Display & Monitor>Compositor

You forgot to use code format.