Radxa Zero Manjaro ARM installation via dd command

Hi, I am trying to installation of Manjaro ARM to eMMC storage. To achive this I created Ubuntu uSD card and booted with this. I downloaded manjaro image from Github and extracted *.img file on Ubuntu uSD. Flashed internal eMMC with “sudo dd if=./Manjaro-ARM.img of=/dev/mmcblk0 bs=1M” and powered off (systemctl poweroff) Radxa Zero. Then unpluged radxa and removed uSD. After that I supplied power and RZ not booted. I checked partitions with “sudo fdisk -l” command and eMMC has two partition but none of them flaged as bootable. I flaged manually and there is no change. With same method I succesfully make bootable Ubuntu on eMMC. I am insisting on Manjaro because its more recent and better GUI than Debian (Ubuntu do not have desktop environment).
Anyone can help me? Thanks.

Sounds like eMMC support is not in the kernel yet. Maybe @spikerguy knows.

Have you tried Manjaro from uSD?

Hi, I tried from uSD card and works smooth but I believe eMMC performance more better. I want to make Manjaro to my main OS and create other distribuions on uSD cards. Thanks.

1 Like

I have to check on what uboot we uaed by default.

I don’t think there is a uboot with mmc but let me try out tonight.