Radiotray-ng app-level volume control via mousewheel on indicator stopped working

It is nota new issue but I realize that it works for another user in the same laptop and get a hope.
Normally, whirling the mouse wheel on the indicator raises or lowers the app-level volume. In some point, it spotted working. At first I thought it is either an appindicator or an app problem, since other indicators are giving response to mousewheel events. As I said, however, it works for another user in my computer with plasma desktop.
I tried to remove panel and reset my user files, such as kdeglobal, *rc, etc. I even try to replace some files with the second user’s ones that I thought related.
By the way, it was not the only issue with radiotray indicator. The other issue seems fixed after I installed libayatana-appindicator. It was only a trial-error thing.
Is there a way to fix or at least inquire the issue?

Radiotray-NG: v0.2.8-dev (v0.2.7-6-g1f6e18b)
OS: Manjaro 20.1 Mikah
Kernel: x86_64 Linux 5.8.6-1-MANJARO
DE: KDE 5.73.0 / Plasma 5.19.5
WM: KWin

edit: I tried to remove the app and purge all radiotray* files, and reinstall it. It creates a radiotray-ng.desktop file under /etc/xdg/autostart folder and autostarts with system. Interesting things occur then. If it autostarts with the system its tray icon responds to mousewheel and volume changes, however, middle-click pause-play stops working. If I quit the app and restart it from its launcher, mousewheel stops and middle-click play-pause works. I am only a curious cat now, how it works, how kde works, etc :slight_smile:

Regardless the version, is/are AUR packages.
Moved from #desktop-environments:Plasma to #support:aur

The integratin with the new KDE Plasma tray has to be done by their developers. Eventually you can edit the radiotray-ng.desktop file in the

and add 5s delay to the Exec line.
Exec=sleep 5s && radiotray-ng
It might help, but no guarantee.

Also an AUR package. Make sure you have a look at their pages and see the comments form people there.

Thank you for your help.
I had allready tried to delay.
radiotray-ng developer is also aware of such problems in KDE and thinks that it is an appindicator problem: App-Level Volume Adjustment Using Mouse-Scroll-Wheel in KDE · Issue #152 · ebruck/radiotray-ng · GitHub
I think it is a tiny problem, by the way. Global shortcuts may help to use app-level volume for example, radiotray-ng has a dbus interface for that, and I don’t have any other indicator problems in KDE.
Actuall now I just curious about how the autosart and “ordinary” start can be different, and what things could I messed up for one user while the app works as expected for another user. But I assume it is a bit beyond of my level of linux knowledge and digging ability :slight_smile: I have great respect for developers as an ordinary user and want to thank you.