Radeon RX 6700 XT cannot start display manager / black screen

I got a new pc this weekend and I am struggling to get the graphics card to work.

My system:
CPU: AMD Ryzen 7 5800X
GPU: Gigabyte AMD Radeon RX 6700 XT
Mainboard: MSI B550-A Pro
OS: Manjaro

I wanted to reuse my SSD with manjaro for this pc. The old install had an amd card as well (radeon RX 640)
Whenever I boot i arrive at a blinking cursor. Terminals work as expected fortunately.
Looking into journal I get the following error:

Devices detected, but none match those in the config file
Fatal Server error:
no screens found

I tried several things so far:

  • uninstalling old amd drivers via mhwd
  • installing new drivers via mhwd (tested free and nonfree)
  • reinstalling mesa,vulkan, etc by hand
  • adding ExecStartPre=/bin/sleep 2 to gdm.service config (some threads suggested that the dm is loaded before the driver were able to be loaded)
  • added Modules into mkinitcpio (beforehand it was empty, now MODULES=(amdgpu radeon) )
  • removing the card alltogether and trying to use the onboard radeon HD card (didn’t work either, could even see bios with that one)
  • manually restarted lightdm service
  • Using inxi to figure out what is loaded
  • trying to figure out how to install the radeon driver from their website (I don’t find any arch compatible version)
  • Created a bootable usb stick with manjaro via terminal and booted from it with the same result. with free and nonfree drivers
  • tried to remove mesa to install mesa-git (experimental) but mesa has too many dependencies (for example mhwd) to uninstall
  • checked my bios version. I have the latest version already

I am gonna provide some pictures in a few min (switching to smartphone for editing)
Edit: I cannot post pictures so I am trying to type the most important information

Inxi -Gazy output here:

Device-1: AMD Navi 22 vendor: Gigabyte driver: N/A bus-ID: 2d:00.0
chip-ID: 1002:73df class-ID: 0300
Display: server: X.org 1.20.11 driver: loaded: ati, radeon
unloaded: modesetting alternate: fbdev,vesa tty: 128x48
Message: Advanced graphics data unavailable in console for root.

Journal log here:

(II) LoadModule: "radeon"
(II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
(II) Module radeon: vendor="X.org Foundation"
compiled for 1.20.8, module version = 19.1.0
Module class: X.org Video Driver
ABI class: X.Org Video Driver, version 24.1
(II) RADEON: Driver for ATI/AMD Radeon chipsets:
... list of Radeon chipsets
(II) modesetting: Driver for Modesetting Kernel Drivers: kms
(EE) open /dev/dri/card0: no such file or directory
(ww) Falling back to old probe method for modesetting
(WW) VGA arbiter cannot open kernel arbiter, no multi-card support
(EE) Screen 0 deleted because of no matching config section
(II) UnloadModule: "modesetting"
(EE) Devices detected, but none match those in the config file.
(EE) Fatal server error:
(EE) no screens found(EE)

Interestingly the journal shows that the radeon driver provides a lot of chipsets but the RX 6700 XT is not listed. So i am guessing that the driver for some reason is not really installed?

Any help is greatly appreciated. I am scrambling through threads for 3 days now.

The recommended driver for the newer cards right now is the video-linux driver aka amdgpu.
Are you perhaps on an older kernel? Complete support for the newer cards has just arrived in 5.12, so that might be worth a try. Alternatively the 5.10 version had decent support for my 6800XT.
You might also need to check and change your Xorg config, to represent your new system and how everything is connected.

Oh, that would explain the missing entry inside the list of chipsets, I guess?

I am on 5.10.34-1 right now. Upgraded to 5.12 now via mhwd-kernel…

and it works! I guess stable is 2 kernel versions behind? maybe I should switch to a different channel to have the best support for this hardware?

Anyway thanks so much. I am trying to clean up any leftovers from my tries now.
Have a nice remaining weekend!

No, you don’t need to switch to another channel… it’s just that you have to choose which kernel you want to run.
You might still have the old metapackage installed. I would recommend removing it.

1 Like

Ah, I see. I will check periodically from now on (coming from rolling release arch this flew under my radar). Maybe there is a notification tool for new kernels that helps me with keeping up :slight_smile:
I uninstalled the linux-latest which in turn removed the old kernel as well. So far the system runs very pleasantly.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.