R9 290 help sea island, modprobe.d config

hi recently tried to switch to manjaro from win10,i`m noob, im tryng to run some games but wont run, i dig a bit on the web and maybe i found somethings, since my gpu is a sea island i have to enable in the kernel i read the arch wiki but im a bit confused on how to do it

Set one of the following kernel parameters:

    Southern Islands (SI): radeon.si_support=0 amdgpu.si_support=1
    Sea Islands (CIK): radeon.cik_support=0 amdgpu.cik_support=1

Set module parameters in modprobe.d

Create the configuration modprobe files in /etc/modprobe.d/, see modprobe.d(5) for syntax details.

For Southern Islands (SI) use option si_support=1, for Sea Islands (CIK) use option cik_support=1, e.g.:


options amdgpu si_support=1
options amdgpu cik_support=1


options radeon si_support=0
options radeon cik_support=0

Make sure modconf is in the the HOOKS array in /etc/mkinitcpio.conf and regenerate the initramfs. `````
this is what i think i have to do but i dont know how to do it

Hello @alessiouchiha91 :wink:

This does the same thing automatically:

pamac install amdgpu-experimental

Here is the source: Packages / Community / amdgpu-experimental · GitLab

1 Like

i`ve done it but still not working

See my post … They dont care … go to other forums like LTT for more help :wink:

I gave you an honest answer, not my fault if you don’t like it, it’s a community forum not a customer service.