QuodLibet (Flatpak) does not play ALAC and APE files

QuodLibet 4.5.0-1 from Manjaro Official Community Repositories with gstreamer 1.20.5-1 on Manjaro 22.0.0 Sikaris, running the x86_64 Linux 6.1.1-1-MANJARO kernel plays ALAC and APE files on my system.

I run pipewire 0.3.63-1 with wireplumber 0.4.13-1 on wayland 1.21.0-2 and GNOME 43.2.

The Flatpak version 4.5.0 from Flathub does not play ALAC and APE files.

I am inexperienced with tracking down log output for Flatpak apps. When launching QuodLibet with flatpak run I do not get any output in the logs (nor wiht journalctl) when QuodLibet shows an error prompt when attempting to play ALAC or APE files.

I tried to install a bunch of gstreamer plugin packages but none of them resolved the issue for me.

Why are trying to use the FlatPak version rather than the one from the repo? Especially if the one from the repo works.



QuodLibet 4.5.0-1 from Manjaro Official Community Repositories plays ALAC and APE files.
Lovely, I love a binary package for FOSS software.

QhodLibet 4.5.0 Flatpak doesn’t work.
Who gives a toss? Why would anyone skip repos and get more bloated Flatpaks unless they want a function that isn’t working?

What is your question? I’m too stupid to get my head around this one…

1 Like

@Ben @NGr Hahaha, you are right! First, thanks for your replies guys! I appreciate your help!

I guess I’m too compulsive/stubborn sometimes. :wink: I started a while ago to manage everything that is GNOME and Manjaro via the official repositories and to all third party software via Flatpak. I don’t like the “space wasting” aspect of Flatpak either. However, I would still be interested to know why the Flatpak version cannot play ALAC files. :slight_smile:

1 Like