Quick menu looks ugly after upgrade to gnome 43

After recent update, my quick menu looks ugly, icons are too big, and also the calendar widget looks too big. Can anyone help me figure out what’s the problem?
My screen resolution is 1920x1080
I already tried rename ~/.local/share and ~/.config . After reboot I think the system was reset, however, the icon/widget size are still too big. Also, checked the Display->Scale setting. It’s set to 100%

Unfortunately, I can’t embed images here, and share links either. Maybe missing some deps?


Hi @bsvTag, and welcome!

Try clearing the cache:

mv ~/.cache ~/cache.backup

this will move the cache to a backup.

Followed by a reboot.

If all is working after the reboot, feel free to delete the backup:

rm -rf ~/cache.backup

It might also be that the theme isn’t compatible with the newer version after the upgrade. So check that out as well. Try using a different theme.

Not using Gnome myself, that is all I can suggest.

1 Like

Partially the problem is resolved after I switched theme in gnome extension ‘User themes’. However, the top bar together with widgets on it and quick menu are in the light theme regardless dark mode is on.

1 Like



1 Like

Thanks anyway!

1 Like

i have the same problem since update

Is your theme for Shell set to default, Mine is set to default with “Tweaks” Tool.

And i use Dash to Panel and remove the original topbar, And have it set to look like Gnomes topbar.

ok whith Shell set to default! Merci!

It’s strange, but i have warning icon near shell select and couldn’t choose any option there. Any ideas, how can this be resolved?

I went to extensions, and turn ‘User Themes’ On. After that shell select is enabled. Unfortunatelly, I have Default option set. However, it doesn’t solve the problem

The issue is solved!
There was a conflict between manjaro-gnome-settings and manjaro-gdm-* package(unfortunately forgot original name)
Just tried the following command:
sudo pacman -S manjaro-gnome-settings manjaro-settings-manager
And follow instructions to resolve the conflict.


This works with Matcha-sea. I just upgraded and had the same weird look. It now looks decent and so much better than anything Gnome devs could ever achieve with their crappy (lib)adwaita theme.

Only problem is the inconsistent blue highlight in gdm.

I’m sick of blue on themes. It doesn’t look good on a computer theme in my opinion. Dark/black and (quite dark) blue very rarely bode well together. I’m not even following fashion but every sane person knows that.

And it’s inconsistent with Manjaro colors (green/teal).

How can I get the manjaro color back in gdm?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.