Questions about importing GPG keys

The other day, I asked a question in the community about a similar title.
it’s here
But then I found out that all GPG keys could not be imported.

$ gpg --recv-keys 9BA2A5A630CBEA53
gpg: 从公钥服务器接收失败:服务器故障

The way I found online is to replace the server, but the same error still occurs no matter which server is used.
Also, the problem seems to be after the “gnupg” package was updated to 2.2.40-1.
But I also tried a similar operation in the virtual machine, but the virtual machine can import the key normally.
Do you have any other research ideas?

What if you try:
gpg --keyserver hkps:// --recv-key 9BA2A5A630CBEA53

Tip: If you add the following to your ~/.gnupg/gpg.conf, you won’t need to specify the server manually in the future:

keyserver hkps://
keyserver-options timeout=10

Thank you for your answer, but this method has been tried before I asked, still the same error.
I don’t think it’s a network problem.

I do. Either way it’s something locally on your end. No one else can reproduce it. The key is available on the keyserver.

thank you for your reply.
I see that the “gnupg” of archlinux is out of date, and my problem also appeared after the update. I can try to wait for its next update.

…is unrelated. gnupg 2.2.39-1 is still in the Manjaro stable branch that’s been around for almost two months and 2.2.40-1 is in the testing and unstable branches.

Again, no one else can reproduce your issue.

thank you for your reply.
All I’m using is the unstable branch, I can wait a little longer.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.