Question about boost-libs=1.74.0 and vpn-unlimited

I have installed the current version of manjaro mate on two computers. Using the AUR, I was able to install vpn-unlimited without any problems on one computer, but the dependencies refuse to work on the other.

Before I go searching for a wolf, I thought I’d ask the professionals.

Well there’s not much information to go on, please post any errors you get.

For now I’ll suggest that you may need to install base-devel.

sudo pacman -S base-devel

1 Like

base-devel is installed

Warnung: vpn-unlimited ist nur vom AUR verfügbar
Klone vpn-unlimited Build-Dateien...
Generiere vpn-unlimited Informationen...
Überprüfe vpn-unlimited Abhängigkeiten...
Überprüfe qt5-webkit Abhängigkeiten...
Abhängigkeiten werden aufgelöst...
Warnung: Kann "boost-libs=1.74.0" nicht auflösen (eine Abhängigkeit von "vpn-unlimited")
Fehler: Vorgang konnte nicht erfolgreich vorbereitet werden:
Kann Abhängigkeiten nicht erfüllen:
- nicht vorhandene Abhängigkeit 'boost-libs=1.74.0' benötigt von vpn-unlimited

Build-Dateien bearbeiten : [e] 
Transaktion anwenden ? [e/j/N] j

Vorgang abgebrochen.

It seems to be relying on an outdated version, that is no longer available in either the repos or the AUR.

You could try changing this line


to this

However there's this comment on the AUR page:
No workaround for boost-libs=1.74 in near sight, though?

Not to my knowledge. They’ve linked to version 1.74 because that’s what’s available on Debian Bullseye. I don’t think it’s possible patch the executable to use 1.81 so’s, but I’d be happy to do so if there was a way. Debian Experimental has 1.81 but I guess that’s years away.

The only think I can think of would be to reach out to them and ask them to not link explicitly to version 1.74, or to statically link Boost.


The package maintainer should be notified so they can correct the PKGBUILD.

1 Like

Try this:

pamac build boost174-libs vpn-unlimited

I will try to change the entry to boost-libs. The crazy thing is that it worked under the same distribution on one computer and not on the other. That’s what puzzles me.

Oops missed that one.

1 Like

Ok … looks good … will check back after compiling on an old macmini … think in 3 hours ^^


Thank You All! Problem is solved. Great work.
I tried about 5 years to get that to work before under Linux.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.